poj_2299 Ultra-QuickSort(归并排序/树状数组 求逆序对)

3 篇文章 0 订阅
1 篇文章 0 订阅
Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 57323 Accepted: 21183

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
利用归并排序的性质求逆序对,要注意最后输出值较大 要用long long。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 500010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int n;
int a[maxn];
int t[maxn];
LL ans = 0;

void Merge(int l, int m, int r)
{
    int i = l, j = m+1, cot = l;
    while(i <= m && j <= r)
    {
        if(a[i] > a[j]) t[cot++] = a[j++], ans += m - i + 1;
        else t[cot++] = a[i++];
    }
    while(i <= m) t[cot++] = a[i++];
    while(j <= r) t[cot++] = a[j++];
    for(i = l; i <= r; i++) a[i] = t[i];
}

void Msort(int l, int r)
{
    if(l < r)
    {
        int m = l + r >> 1;
        Msort(l, m);
        Msort(m+1, r);
        Merge(l, m, r);
    }
}

int main()
{
    while(scanf("%d", &n) && n)
    {
        ans = 0;
        for(int i = 0; i < n; i++) scanf("%d", &a[i]);
        Msort(0, n-1);
        printf("%lld\n", ans);
    }
    return 0;
}


 
也可以离散(也就是排序后用较小的数去代替原数)后用树状数组的性质做。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 500010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

struct Node
{
    int v, pos;
}a[maxn];

int n;
int aa[maxn]; //离散之后的数组
int c[maxn];  //树状数组

bool compare(Node a, Node b)
{
    return a.v < b.v;
}

int lowbit(int i)
{
    return i & (-i);
}

void update(int i, int val)
{
    while(i <= n)
    {
        c[i] += val;
        i += lowbit(i);
    }
}

int Sum(int x)
{
    int ans = 0;
    while(x > 0)
    {
        ans += c[x];
        x -= lowbit(x);
    }
    return ans;
}

int main()
{
    while(scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i].v);
            a[i].pos = i;
        }
        sort(a+1, a+n+1, compare);
        for(int i = 1; i <= n; i++) aa[a[i].pos] = i;

        memset(c, 0, sizeof(c));
        LL ans = 0;
        for(int i = 1; i <= n; i++)
        {
            update(aa[i], 1);
            ans += i - Sum(aa[i]);
        }
        printf("%lld\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值