poj_2151 Check the difficulty of problems(概率dp)

10 篇文章 0 订阅
1 篇文章 0 订阅
Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7053 Accepted: 3051

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972
 
概率dp,要求求出所有队伍至少求出一道题,同时冠军队伍至少求出N道题的概率,注意冠军队伍可以不止一支。
可以转化成 所有队伍至少求出一道题的概率 - 所有队伍求出1~(N-1)道题的概率。
一开始求至少求出一道题的概率时理所应当地以为等于 1 - 队伍一道题都求不出来的概率,
事实上队伍求出题目的概率可以不等于1。所以还需要求出 队伍至多求出M道题的概率 和 队伍至多求出N-1道题的概率,
这样上面至少一题和1~(N-1)的概率就可以解了。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int M, T, N;
double dp[1002][32][32]; //第i队在前j题中做出k道题的概率
double p[1002][32]; //第i队做出第j题的概率
double s[1002][32]; //第i队至多做出k道题的概率

int main()
{
    while(scanf("%d%d%d", &M, &T, &N) && (M != 0 || T != 0 || N != 0))
    {
        memset(dp, 0, sizeof(dp));
        memset(s, 0, sizeof(s));

        for(int i = 1; i <= T; i++)
        {
            for(int j = 1; j <= M; j++) scanf("%lf", &p[i][j]);
        }
        for(int i = 1; i <= T; i++)
        {
            dp[i][1][0] = 1 - p[i][1], dp[i][1][1] = p[i][1];

            for(int j = 2; j <= M; j++)
            {
                for(int k = 0; k <= j; k++)
                {
                    if(k == 0) dp[i][j][k] = dp[i][j-1][k] * (1 - p[i][j]);
                    else dp[i][j][k] = dp[i][j-1][k-1] * p[i][j] + dp[i][j-1][k] * (1 - p[i][j]);
                }
            }
            s[i][0] = dp[i][M][0];
            
            for(int k = 1; k <= M; k++) s[i][k] = s[i][k-1] + dp[i][M][k];
        }
        double ans1 = 1, ans2 = 1;
        
        for(int i = 1; i <= T; i++) ans1 *= s[i][M] - s[i][0], ans2 *= s[i][N-1] - s[i][0];
        
        printf("%.3f\n", ans1 - ans2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值