poj 2151 Check the difficulty of problems(概率DP)

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

  1. All of the teams solve at least one problem.
  2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?
Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0
Sample Output
0.972

题意

有t支队伍和m道题目,求每只队伍都做出至少一题,且至少有一只队伍做出至少n题的概率

思路

首先可以很快的求出来的是 f [ i ] [ k ] f[i][k] f[i][k],表示第 i i i支队伍解出恰好 k k k题的概率。

这个可以用DP求解, f [ i ] [ j ] [ k ] f[i][j][k] f[i][j][k]表示第 i i i支队伍在前 j j j题中解出恰好 k k k题的概率,可以省掉一维,就变成了上述的 f [ i ] [ j ] f[i][j] f[i][j]

然后考虑题目的条件,首先要满足每队至少做出一题。可以很方便的用 ∏ i = 1 t ( 1 − f [ i ] [ 0 ] ) \prod_{i = 1}^{t} (1-f[i][0]) i=1t(1f[i][0])求出来。

在此基础上,还要至少一个队大于等于n道。题目这样的说法非常难搞,好像要用到容斥原理才能正面求出。所以我们考虑他的补集,即所有队伍都做掉了小于n道题,(在全集每队至少做出一题中,即所有队伍做出了1~n-1道题,即 ∏ i = 1 t ∑ j = 1 n − 1 f [ i ] [ j ] \prod_{i=1}^{t} \sum_{j=1}^{n-1}f[i][j] i=1tj=1n1f[i][j]

That’s all.非常基础的概率DP,然而我第一次还是没有凭借自己的力量做出来。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int M = 50;
const int T = 1010;
int m, t, n;
float p[T][M], f[T][M], p1, p2;


int main()
{
    while (scanf("%d%d%d", &m, &t, &n) == 3 && n+m+t){
        for (int i = 1; i <= t; i++)
            for (int j = 1; j <= m; j++)
                scanf("%f", &p[i][j]);
        memset(f, 0, sizeof(f));
        for (int i = 1; i <= t; i++){
            f[i][0] = 1;
            for (int j = 1; j <= m; j++)
                for (int k = m; k >= 0; k--){
                    if (k == 0) f[i][k] = f[i][k]*(1-p[i][j]);
                    else f[i][k] = f[i][k]*(1-p[i][j])+f[i][k-1]*p[i][j];
                }
        }
        p1 = 1;
        for (int i = 1; i <= t; i++)
            p1 *= (1.0-f[i][0]);
        p2 = 1;
        for (int i = 1; i <= t; i++){
            float tmp = 0;
            for (int j = 1; j < n; j++)
                tmp += f[i][j];
            p2 *= tmp;
        }
        printf("%.3f\n", p1-p2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值