poj_1416 Shredding Company(dfs)

16 篇文章 0 订阅
10 篇文章 0 订阅
Shredding Company
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5684 Accepted: 3190

Description

You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics. 

1.The shredder takes as input a target number and a sheet of paper with a number written on it. 

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it. 

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it. 

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50. 
 
Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


There are also three special rules : 

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut. 

For example, if the target number is 100 and the number on the sheet of paper is also 100, then 

the paper is not cut. 

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed. 

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number. 

Input

The input consists of several test cases, each on one line, as follows : 

tl num1 
t2 num2 
... 
tn numn 
0 0 

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded. 

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input. 

Output

For each test case in the input, the corresponding output takes one of the following three types : 

sum part1 part2 ... 
rejected 
error 

In the first type, partj and sum have the following meaning : 

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper. 

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +... 

Each number should be separated by one space. 
The message error is printed if it is not possible to make any combination, and rejected if there is 
more than one possible combination. 
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line. 

Sample Input

50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output

43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected
 
比较有趣的碎纸机题。
dfs递归切纸。
例如样例1:50 12346
 
                      12346       
                       / \
       (1,2346) (12,346) (123,46) (1234,6)
           / \       
  (2,346) (23,46) (234,6) 
      /\
 (3,46)(34,6)
    /\
  (4,6)
 
每次递归时,加上括号内左边的数作为参数,对括号内右边的数继续递归。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define FOP2 freopen("data1.txt","w",stdout)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int paper[10];
int len;
int target;

int ansl[10];
int ans;
int temp[10];
int flag;
int cot;

int getNum(int l, int r)
{
    int res = 0;
    for(int i = l; i <= r; i++)
    {
        res = res * 10 + paper[i];
    }
    return res;
}

void dfs(int sum, int pos, int c)
{
    int a, b, t;
    for(int i = pos; i < len; i++)
    {
        a = getNum(pos, i);
        b = getNum(i+1, len);
        t = sum + a + b;

        temp[c] = a;

        if(t <= target)
        {
            if(ans < t)
            {
                flag = 1;
                temp[c+1] = b;
                for(int i = 1; i <= c+1; i++) ansl[i] = temp[i];
                cot = c+1;
                ans = t;
            }
            else if(ans == t)
            {
                flag = 2;
            }
        }
        
        dfs(sum+a, i+1, c+1);
    }
}

int main()
{
    //FOP;
    //FOP2;
    char s[10];
    while(~scanf("%d%s", &target, s) && (target != 0 || s[0] != '0'))
    {
        ans = 0;
        flag = 0;
        len = strlen(s);
        for(int i = 0; i < len; i++) paper[i+1] = s[i]-'0';

        int t = getNum(1, len);
        if(t <= target)
        {
            flag = 1;
            ansl[1] = t;
            cot = 1;
            ans = t;
        }

        dfs(0, 1, 1);

        if(flag == 1)
        {
            printf("%d ", ans);
            for(int i = 1; i <= cot; i++)
            {
                printf("%d", ansl[i]);
                if(i != cot) printf(" ");
            }
            printf("\n");
        }
        else if (flag == 2) printf("rejected\n");
        else printf("error\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值