UVaOJ127---"Accordian" Patience

127 - "Accordian" Patience

Time limit: 3.000 seconds

You are to simulate the playing of games of ``Accordian'' patience, the rules for which are as follows:

Deal cards one by one in a row from left to right, not overlapping. Whenever the card matches its immediate neighbour on the left, or matches the third card to the left,  it may be moved onto that card. Cards match if they are of the same suit or same rank. After making a move, look to see if it has made additional moves possible. Only the top card of each pile may be moved at any given time. Gaps between piles should be closed up as soon as they appear by moving all piles on the right of the gap one position to the left. Deal out the whole pack, combining cards towards the left whenever possible. The game is won if the pack is reduced to a single pile.

Situations can arise where more than one play is possible. Where two cards may be moved, you should adopt the strategy of always moving the leftmost card possible. Where a card may be moved either one position to the left or three positions to the left, move it three positions.

Input

Input data to the program specifies the order in which cards are dealt from the pack. The input contains pairs of lines, each line containing 26 cards separated by single space characters. The final line of the input file contains a # as its first character. Cards are represented as a two character code. The first character is the face-value (A=Ace, 2-9, T=10, J=Jack, Q=Queen, K=King) and the second character is the suit (C=Clubs, D=Diamonds, H=Hearts, S=Spades).

Output

One line of output must be produced for each pair of lines (that between them describe a pack of 52 cards) in the input. Each line of output shows the number of cards in each of the piles remaining after playing ``Accordian patience'' with the pack of cards as described by the corresponding pairs of input lines.

Sample Input

QD AD 8H 5S 3H 5H TC 4D JH KS 6H 8S JS AC AS 8D 2H QS TS 3S AH 4H TH TD 3C 6S
8C 7D 4C 4S 7S 9H 7C 5D 2S KD 2D QH JD 6D 9D JC 2C KH 3D QC 6C 9S KC 7H 9C 5C
AC 2C 3C 4C 5C 6C 7C 8C 9C TC JC QC KC AD 2D 3D 4D 5D 6D 7D 8D TD 9D JD QD KD
AH 2H 3H 4H 5H 6H 7H 8H 9H KH 6S QH TH AS 2S 3S 4S 5S JH 7S 8S 9S TS JS QS KS
#

Sample Output

6 piles remaining: 40 8 1 1 1 1
1 pile remaining: 52
#include <algorithm>
#include <iostream>
#include <string>
#include <cstring>
#include <vector>
using namespace std;
//CARD结构体,存储一张牌,Face[0]表示花色,Face[1]表示点数
struct CARD {char Face[2];} Src;
//比较两张牌是否匹配。花色或点数相同即匹配
inline bool Match(const CARD &c1, const CARD &c2) {
    return (c1.Face[0] == c2.Face[0] || c1.Face[1] == c2.Face[1]);
}
int main(void) { //主函数
    typedef vector<CARD> PILE;
    char Pack[256]; //用于存储输入的一副牌,下面循环读取输入的数据
    for (string Line; getline(cin, Line) && Line[0] != '#'; cout << endl) {
        strcpy(Pack, Line.c_str()); //读取并处理输入的数据
        while (getline(cin, Line) && Line.empty()); //读取第2行
        strcat(Pack, Line.c_str());
        *remove(&Pack[0], &Pack[strlen(Pack)], ' ') = '\0'; //删除行中的空格
        vector<PILE> Piles;
        for (int i = 0; i < 52; ++i) { //循环发出每一张牌
            PILE Stack(1, ((CARD*)&Pack)[i]);
            Piles.push_back(Stack); //将新发的牌放在最后一叠
            //j表示当前牌的位置,k表示j左边与之匹配的牌的位置
            for (size_t j = Piles.size() - 1, k; j < Piles.size(); ++j) {
                //以下循环向左查找可以移到的最左边的位置
                for (k = j, Src = Piles[j].back(); k > 0; --k) {
                    if (k >= 3) { //先判定左边是否存在第3张
                        if (Match(Src, Piles[k - 3].back())) {
                            //如果与左边第3张匹配,则将k指向这张牌
                            k -= 2;
                            continue;
                        } //虚拟移到k指向的位置,继续向左查找
                    }
                    if (!Match(Src, Piles[k - 1].back())) {
                        break; //如果左边第3张和第1张都失配,跳出循环
                    }
                }
                if (k != j) { //k与原位置j不相等表示可以移动
                    Piles[k].push_back(Piles[j].back()); //移动牌
                    Piles[j].pop_back();
                    if (Piles[j].empty()) { //如果牌叠被移空则删除之
                        Piles.erase(Piles.begin() + j);
                    }
                    j = k; //将移动牌查找的起点定为k
                }
            }
        } //以下按要求的格式输出结果。注意到Pile有单复数的区分
        int nSize = Piles.size();
        cout << nSize << " pile" << (nSize > 1 ? "s " : " ") << "remaining:";
        for (int i = 0; i < nSize; cout << ' ' << Piles[i++].size());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值