UVaOJ270 - Lining Up

270 - Lining Up

Time limit: 3.000 seconds

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

const int MAXN = 705;
struct Point {
    int x, y;
}point[MAXN];
int nIndex;
char str[10000];
void init_input() {
    nIndex = 0;
    while (gets(str)) {
        if (! str[0]) break;
        sscanf(str, "%d%d", &point[nIndex].x, &point[nIndex].y);
        nIndex ++;
    }
}
inline bool is_lined(const int x1, const int y1, const int x2, const int y2, const int x3, const int y3) {
    return (x2 - x1) * (y3 - y2) - (x3 - x2) * (y2 - y1) == 0;
}
void solve() {
    int maxNum = 2;
    for (int i = 0; i < nIndex; i ++) {
        for (int j = i + 1; j < nIndex; j ++) {
            int cnt = 2;
            for (int k = j + 1; k < nIndex; k ++) {
                if (is_lined(point[i].x, point[i].y, point[j].x, point[j].y, point[k].x, point[k].y)) {
                    cnt ++;
                }
            }
            if (cnt > maxNum) {
                maxNum = cnt;
            }
        }
    }
    printf("%d\n", maxNum);
}
int main() {
    int T;
    scanf("%d%*c", &T);
    gets(str);
    while (T --) {
        init_input();
        if (nIndex == 1) {
            printf("1\n");
        } else if (nIndex == 2){
            printf("2\n");
        } else {
            solve();
        }
        if (T) {
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值