UVaOJ674 - Coin Change

674 - Coin Change

Time limit: 3.000 seconds

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11
26

Sample Output

4
13



Miguel Revilla 
2000-08-14

题目大意:

            给定一个数n,问5个数1、5、10、25、50相加之和为n的组合个数,1,5,5和5,5,1算一种..

题目分析:     

          简言之,添不添加当前硬币金额,子状态分别对应dp[j-coin[i]]与dp[j],由于二者不能同时发生,故当判断条件为真时(需要添加当前硬币),

 dp[j] = dp[j] + dp[j-coin[i]],否则dp[j]不作任何修改。

源代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int MAXN = 7490;
int dp[MAXN];
int coin[5] = {1, 5, 10, 25, 50};
void slove () {
    dp[0] = 1;
    for (int i = 0; i < 5; i ++) {
        for (int j = 1; j < MAXN; j ++) {
            if (j >= coin[i]) {
                dp[j] += dp[j - coin[i]];
            }
        }
    }
}
int main() {
    int n;
    slove();
    while (scanf("%d", &n) != EOF) {
        printf("%d\n", dp[n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值