A - Max Sum Plus Plus——POJ

A - Max Sum Plus Plus
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S  1, S  2, S  3, S  4 ... S  x, ... S  n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S  x ≤ 32767). We define a function sum(i, j) = S  i + ... + S  j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i  1, j  1) + sum(i  2, j  2) + sum(i  3, j  3) + ... + sum(i m, j  m) maximal (i  x ≤ i  y ≤ j  x or i  x ≤ j  y ≤ j  x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i  x, j  x)(1 ≤ x ≤ m) instead. ^_^ 
 

Input

Each test case will begin with two integers m and n, followed by n integers S  1, S  2, S  3 ... S  n
Process to the end of file. 
 

Output

Output the maximal summation described above in one line. 
 

Sample Input

     
     
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output

     
     
6 8

Hint

 Huge input, scanf and dynamic programming is recommended. 
         
 




动规方程:

dp[i][j]=前j个数选择i段的最大值

dp[i][j]=max(dp[i][j-1]  ,  max{dp[i-1][k]}  )+a[j]  (i-1<=k<=j-1)

i独立成段:

其不独立成段,既与j-2成段




#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef __int64 LL;

int a[maxn],dp[maxn];
int pre[maxn];//对应递推式的第二项
int main()
{
    int T;
    //freopen("Text//in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=1;i<=n;i++)
		{
            scanf("%d",a+i);
            dp[i]=pre[i]=0;
        }
        int mx;
        dp[0]=pre[0]=0;
        for(int i=1;i<=m;i++)
	{
            mx=-999999999;
            for(int j=i;j<=n;j++)
	    {
                dp[j]=max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=max(dp[j],mx);
            }
        }
        printf("%d\n",mx);
    }
    return 0;
}






 for(int j=i;j<=n;j++)
{
                dp[j]=max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=max(dp[j],mx);
}

蓝色的表示其最大值



下面我来解释其具体怎么实现:

利用了动态数组,只保留了当前行和上一行,因为动规方程只用的到这两行,

pre【i】为上上一行i之前的最大值

而dp【i】则保留当前行

 for(int j=i;j<=n;j++)
{
                dp[j]=max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=max(dp[j],mx);
}

先利用上一行的j-1数据用于动规方程,

然后把pre[j-1]=mx赋值为当前行的前[j-1]行最小值

这样就保证了,pre[]向下循环

一下代码用于测试;


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef __int64 LL;

int a[maxn],dp[maxn];
int pre[maxn];//对应递推式的第二项
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&m,&n))
	{
        for(int i=1;i<=n;i++)
		{
            scanf("%d",a+i);
            dp[i]=pre[i]=0;
        }
        int mx;
        dp[0]=pre[0]=0;
        for(int i=1;i<=m;i++)
		{
            mx=-99999;
            for(int j=i;j<=n;j++)
			{
                dp[j]=max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=max(dp[j],mx);
                printf("\ndp:\n");
                for(int k=1;k<n;k++)
                	printf("%d ",dp[k]);
                printf("\npre\n");
                for(int k=1;k<n;k++)
                	printf("%d ",pre[k]);
                printf("\n");
            }
            printf("\n*********************************\n");
        }
        printf("%d\n",mx);
    }
    return 0;
}







我把它写简明些:

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef __int64 LL;

int a[maxn],dp[maxn];
int pre[maxn];//对应递推式的第二项
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&m,&n))
	{
        for(int i=1;i<=n;i++)
		{
            scanf("%d",a+i);
            dp[i]=pre[i]=0;
        }
        int mx;
        dp[0]=pre[0]=0;
        for(int i=1;i<=m;i++)
		{
			mx=-99999;//一定是最小,因为当i==j时,其值一定加上a[j] 
            for(int j=i;j<=n;j++)//dp[]中储存当前行,和以前行第一个数 
			{
                dp[j]=max(dp[j-1],pre[j-1])+a[j];//先用 
                pre[j-1]=mx;//后覆盖 
                mx=max(dp[j],mx);//求用于覆盖的最大数 
                
            }
        }
        printf("%d\n",mx);
    }
    return 0;
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值