hdu 1024 Max Sum Plus Plus (dp+二维变一维)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13722    Accepted Submission(s): 4522


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

思路:
dp。
状态:dp[i][j]-最大和    i-已经组成多少组  j-已经用掉多少数。
方程:dp[i][j]=max(dp[i-1][j]+s[i],dp[k][j-1]+s[i]);   (j>=i)  (0<k<i)
时间复杂度为O(n*m^2),dp[k][j-1]可以递推时用一个值维护,降到O(n*m).
由于n比较大,空间吃不消,所以要优化空间。
考虑到第一维每次都是从i-1到i,故可以将第一维去掉。
方程变为 dp[j]=max(dp[j-1]+s[j],ma[j-1]+s[j]);

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 1000005
#define INF 0x3f3f3f3f
using namespace std;

typedef long long ll;
ll n,m,ans;
ll s[maxn],ma[maxn];
ll dp[maxn];

void solve()
{
    int i,j;
    ll t;
    ma[0]=dp[0]=0;
    for(i=1;i<=m;i++)
    {
        t=-INF;
        for(j=i;j<=n;j++)
        {
            dp[j]=max(dp[j-1]+s[j],ma[j-1]+s[j]);
            ma[j-1]=t;
            t=max(t,dp[j]);
        }
        ma[n]=t;
    }
}
int main()
{
    int i,j;
    while(~scanf("%I64d%I64d",&m,&n))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%I64d",&s[i]);
            ma[i]=0;
        }
        solve();
        printf("%I64d\n",ma[n]);
    }
    return 0;
}
/*
1 3
1 2 3
2 6
-1 4 -2 3 -2 3
2 6
-1 -2 -3 -4 -5 -6
*/







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值