kuangbin——线段树专题 G - Can you answer these queries?

G - Can you answer these queries?
Time Limit:2000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help. 
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF. 
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2  63
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6


/*************************************************************************
    > File Name: C.cpp
    > Author:chudongfang 
    > Mail:1149669942@qq.com 
    > Created Time: 2016年08月04日 星期四 08时17分23秒
 ************************************************************************/

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;
typedef long long ll;

#define M 200005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1


ll sum[M<<2];


void pushplus(int rt)
{
    sum[rt] = sum[rt<<1] + sum [rt<<1|1];
}


void build(int l,int r,int rt)
{
    if(l == r)
    {
        scanf("%lld",&sum[rt]);
        return;
    }

    int m = (l+r)>>1;
    build(lson);
    build(rson);
    pushplus(rt);
    
}


void update(int L,int R,int l,int r ,int rt)
{
    if(l == r)
    {
        sum[rt] = (ll)sqrt(sum[rt]);
        return ;
    }
    
    
    int m = (l+r)>>1;
    
    if(L<=m)
        update(L,R,lson);
    if(R>m)    
        update(L,R,rson);
    pushplus(rt);

}


ll query(int L,int R,int l,int r ,int rt)
{
    if(L<=l && r<=R)
    {
        return sum[rt];
    }
    
    int m = (l + r) >>1;
    ll ans = 0;
    if(L <= m)
        ans += query(L,R,lson);
    if(R >  m)
        ans += query(L,R,rson);
    
    return ans;
}





int main(int argc,char *argv[])
{
    int a,b,c,m,n,k=0;
    while((scanf("%d",&n) == 1))
    {
        
        build(1,n,1);
        printf("Case #%d:\n",++k);  
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            if(b>c)  //保证左小右大
            {
                int t;
                t = b;
                b = c;
                c = t;
            }
            if(a == 1)
            {
                printf("%lld\n",query(b,c,1,n,1));
            }
            else 
            {
                if(query(b,c,1,n,1) != c-b+1)  //进行剪枝,1的平方根始终为1
                    update(b,c,1,n,1);
            }
            

        }
        printf("\n");
    }

    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值