Play on Words
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8780 Accepted Submission(s): 3015
Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.
There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
Sample Input
3 2 acm ibm 3 acm malform mouse 2 ok ok
Sample Output
The door cannot be opened. Ordering is possible. The door cannot be opened.
Source
Recommend
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int INF = 1e9;
char s[1005];
int deg[30];
int fa[30];
int vis[30];
int n;
//并查集
int fi(int x){return fa[x]==x?x:fa[x]=fi(fa[x]);}
void uni(int x,int y)
{
x=fi(x),y=fi(y);
fa[x]=y;
}
int main()
{
// freopen("data.txt","r",stdin);
// ios_base::sync_with_stdio(false);
int T;
scanf("%d",&T);
while(T--)
{
memset(vis,0,sizeof(vis));
memset(deg,0,sizeof(deg));
scanf("%d",&n);
for(int i=1;i<=26;i++)
{
fa[i]=i;
}
for(int i=0;i<n;i++)
{
scanf("%s",s);
int len = strlen(s);
int c1 = s[0]-'a';
int c2 = s[len-1]-'a';
//计算出度入度
deg[c1]++;
deg[c2]--;
vis[c1+1]=vis[c2+1]=1;
uni(c1+1,c2+1);
}
int now = 0;
int x=-1;
//判断是否全部联通
for(int i=1;i<=26;i++)
{
fi(i);
// cout <<(char)('a'+i-1)<<" "<< fa[i]<<endl;
if(vis[i])
{
if(x==-1)
{
x=fa[i];
}
else if(fa[i]!=x)
{
now++;
break;
}
}
}
if(now)
{
printf("The door cannot be opened.\n");
continue;
}
//判断出度入度是否合理
int f=0,f1=0,f2=0;
for(int i=0;i<=26;i++)
{
if(deg[i]==1)
{
f1++;
}
else if(deg[i]==-1)
{
f2++;
}
else if(deg[i]!=0)
{
f=1;
break;
}
}
if(f)
{
printf("The door cannot be opened.\n");
continue;
}
if(f1==1&&f2==1||f1==0&&f2==0)
{
printf("Ordering is possible.\n");
}
else
{
printf("The door cannot be opened.\n");
}
}
return 0;
}