C - Recursive sequence HDU - 5950 矩阵快速幂

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.

Input

The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231231 as described above.

Output

For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.

Sample Input

2
3 1 2
4 1 10

Sample Output

85
369

Hint
In the first case, the third number is 85 = 2*1十2十3^4.
In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

 a[i] = a[i-1] + 2*a[i-2] + i^4   
 利用矩阵快速幂,,维护一个a[i]  a[i-1] i^4 i^3 i^2 i 1
 构造出矩阵

难点在于如何构造i^4 利用递推构造 i^3 i^2 i 1,就可以得到答案

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll MOD = 2147493647;

struct matrix{

    ll x[8][8];
};
matrix mutimatrix(matrix a,matrix b)
{
    matrix temp;
    memset(temp.x,0,sizeof(temp.x));
    for(int i=0;i<7;i++)
    {
        for(int j=0;j<7;j++)
        {
            for(int k=0;k<7;k++)
            {
                temp.x[i][j] += ( (a.x[i][k]%MOD)*(b.x[k][j]%MOD) )%MOD;
                temp.x[i][j] %= MOD;
            }
        }
    }
    return temp;
}

matrix powmatr(matrix a,ll n)
{
    matrix temp;
    memset(temp.x,0,sizeof(temp.x));
    for(int i=0;i<7;i++)
    {
        temp.x[i][i]=1;
    }

    while(n)
    {
        if(n&1)
        {
            temp = mutimatrix(temp,a);
        }
        a = mutimatrix(a,a);
        n>>=1;
    }
    return temp;
}



int main()
{
//    freopen("data.txt","r",stdin);
//    ios_base::sync_with_stdio(false);
    int T;
    ll a,b,n;

    matrix cur;


    scanf("%d",&T);
    while(T--)
    {

        memset(cur.x,0,sizeof(cur.x));
        cur.x[0][0]=1;
        cur.x[0][1]=2;
        cur.x[0][2]=1;
        cur.x[0][3]=4;
        cur.x[0][4]=6;
        cur.x[0][5]=4;
        cur.x[0][6]=1;

        cur.x[1][0]=1;
        cur.x[1][1]=0;
        cur.x[1][2]=0;
        cur.x[1][3]=0;
        cur.x[1][4]=0;
        cur.x[1][5]=0;
        cur.x[1][6]=0;

        cur.x[2][0]=0;
        cur.x[2][1]=0;
        cur.x[2][2]=1;
        cur.x[2][3]=4;
        cur.x[2][4]=6;
        cur.x[2][5]=4;
        cur.x[2][6]=1;

        cur.x[3][0]=0;
        cur.x[3][1]=0;
        cur.x[3][2]=0;
        cur.x[3][3]=1;
        cur.x[3][4]=3;
        cur.x[3][5]=3;
        cur.x[3][6]=1;

        cur.x[4][0]=0;
        cur.x[4][1]=0;
        cur.x[4][2]=0;
        cur.x[4][3]=0;
        cur.x[4][4]=1;
        cur.x[4][5]=2;
        cur.x[4][6]=1;

        cur.x[5][0]=0;
        cur.x[5][1]=0;
        cur.x[5][2]=0;
        cur.x[5][3]=0;
        cur.x[5][4]=0;
        cur.x[5][5]=1;
        cur.x[5][6]=1;

        cur.x[6][0]=0;
        cur.x[6][1]=0;
        cur.x[6][2]=0;
        cur.x[6][3]=0;
        cur.x[6][4]=0;
        cur.x[6][5]=0;
        cur.x[6][6]=1;


        scanf("%lld%lld%lld",&n,&a,&b);
        if(n==1)
        {
            printf("%lld\n",a%MOD);
            continue;
        }
        if(n==2)
        {
            printf("%lld\n",b%MOD);
            continue;
        }
        cur = powmatr(cur,n-2);
        matrix ans;
        memset(ans.x,0,sizeof(ans.x));
        ans.x[0][0]=b%MOD;
        ans.x[1][0]=a%MOD;
        ans.x[2][0]=16;
        ans.x[3][0]=8;
        ans.x[4][0]=4;
        ans.x[5][0]=2;
        ans.x[6][0]=1;
        ans = mutimatrix(cur,ans);
        printf("%lld\n",(ans.x[0][0]+MOD)%MOD);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值