poj 2486 Apple Tree (树形dp)

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 … N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

这是一道树形背包的题目……在想状态转移方程的时候因为有回退的情况觉得非常复杂,看题解发现可以通过在dp数组中增加一维来记录是否返回。

用s表示某个根节点,s为它的一个子树,对于经过s的情况只有三种可能,经过子树并返回最终停留在s节点,经过子树t并返回s之后访问另外一边的子树不返回,经过其他子树并返回s之后访问子树t不返回。

dp[root][j][0]=max(dp[root][j][0],dp[root][j-k][0]+dp[son][k][0]);  //返回root,此时son中也要返回并且所能分配的步数减二
dp[root][j][1]=max(dp[root][j][1],dp[root][j-k][1]+dp[son][k-2][0]);    //在root的另一边的子树停留,此时root所对应的分配步数不需要返回,son中需要返回并且能够分配的步数减二
dp[root][j][1]=max(dp[root][j][1],dp[root][j-k][0],dp[son][k-1][1]);    //在son中停留,root从另外一边的结果也要返回,对于son不返回,分配值减一

注意一点:在初始化dp数组时,对于一个节点上每种步数的情况都要将其值初始化为val[i],因为可以在原地不动,因此只要有步数一定可以吃到该点的苹果。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <algorithm>
#define maxn 405
#define inf 0x3f3f3f3f
using namespace std;

vector<int> g[maxn];
int val[maxn],dp[maxn][maxn][2];  //0代表能够回到,1代表不回
int n,k;

void dfs(int now,int fa)
{
   for(int i=0;i<=k;i++)
    dp[now][i][0]=dp[now][i][1]=val[now];
   for(int i=0;i<g[now].size();i++)
   {
       int v=g[now][i];
       if(v==fa) continue;
       dfs(v,now);
       for(int p=k;p>=1;p--)
        for(int j=1;j<=p;j++)
        {
            dp[now][p][0]=max(dp[now][p][0],dp[now][p-j][0]+dp[v][j-2][0]);
            dp[now][p][1]=max(dp[now][p][1],dp[now][p-j][1]+dp[v][j-2][0]);
            dp[now][p][1]=max(dp[now][p][1],dp[now][p-j][0]+dp[v][j-1][1]);

        }
   }
}

int main()
{
    while(cin>>n>>k)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++)
            g[i].clear();
        for(int i=1;i<=n;i++)
        {
            cin>>val[i];
//            for(int j=0;j<=k;j++)
//                dp[i][j][1]=dp[i][j][0]=val[i];
        }
        for(int i=1;i<=n-1;i++)
        {
            int a,b;
            cin>>a>>b;
            g[a].push_back(b);
            g[b].push_back(a);
        }
        dfs(1,0);
        cout<<max(dp[1][k][0],dp[1][k][1])<<endl;

    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值