cocoapods最新踩坑以及更新

原创 2018年04月16日 14:01:26

cocoapods的更新

pod update 报错
[!] Failed to connect to GitHub to update the CocoaPods/Specs specs repo - Please check if you are offline, or that GitHub is down

解决方法

一、升级openssl,先看版本

openssl version

输出:OpenSSL 0.9.8zh 14 Jan 2016

2、输入

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

可能会要你在回车一下,点击回车键

3、更新brew

brew update

ps:如果提示:Error: /usr/local must be writable!

输入:

liuxin$ sudo chown -R $(whoami) /usr/local

4、install openssl

brew install openssl
brew upgrade openssl

5、输入

which openssl
echo 'export PATH="/usr/local/opt/openssl/bin:$PATH"' >> ~/.bash_profile
source ~/.bash_profile

再次查看version

which openssl

输出:/usr/local/opt/openssl/bin/openssl

openssl version

输出:OpenSSL 1.0.2o 27 Mar 2018

二、到这里,openssl就更新完成了,下面更新ruby,输入如下:

brew install rbenv ruby-build
echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bash_profile
echo 'if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi' >> ~/.bash_profile
source ~/.bash_profile

查看当前ruby版本:

ruby --version

输出:ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin16]

我们需要更新到最新的版本,先查看最新版本列表

rvm list known

大概如下,能看到一片内容,找到当前最新到2.4.1

[ruby-]1.8.6[-p420]
[ruby-]1.8.7[-head] # security released on head
[ruby-]1.9.1[-p431]
[ruby-]1.9.2[-p330]
[ruby-]1.9.3[-p551]
[ruby-]2.0.0[-p648]
[ruby-]2.1[.10]
[ruby-]2.2[.7]
[ruby-]2.3[.4]
[ruby-]2.4[.1]

输入:

rvm install 2.4

如果更新报错:Error running ‘requirements_osx_brew_update_system ruby-2.4.1

根据提示操作
打开.bash_profile

open .bash_profile

把source ~/.profile添加进入
如下面所示:

export PATH="/usr/local/opt/openssl/bin:$PATH"
export PATH="$HOME/.rbenv/bin:$PATH"
if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi
source ~/.profile
[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # Load RVM into a shell session *as a function*

再次更新:

1、curl -L get.rvm.io | bash -s stable
2、source ~/.bashrc
3、source ~/.bash_profile
4、rvm -v

然后到这里就更新完了,这个时候,我们就可以导入第三方库
例如:

pod search SDWebImage

输出:

-> SDWebImage (4.0.0)
   Asynchronous image downloader with cache support with an UIImageView
   category.
       pod 'SDWebImage', '~> 4.0.0'
   - Homepage: https://github.com/rs/SDWebImage
   - Source:   https://github.com/rs/SDWebImage.git
   - Versions: 4.0.0, 4.0.0-beta2, 4.0.0-beta, 3.8.2, 3.8.1, 3.8.0, 3.7.6,
   3.7.5, 3.7.4, 3.7.3, 3.7.2, 3.7.1, 3.7.0, 3.6, 3.5.4, 3.5.2, 3.5.1, 3.5, 3.4,
   3.3, 3.2, 3.1, 3.0, 2.7.4, 2.7, 2.6, 2.5, 2.4 [master repo]
   - Subspecs:
     - SDWebImage/Core (4.0.0)
     - SDWebImage/MapKit (4.0.0)
     - SDWebImage/GIF (4.0.0)
     - SDWebImage/WebP (4.0.0)

-> SDWebImage+ExtensionSupport (3.7.1.2)
   Asynchronous image downloader with cache support with an UIImageView
   category. Added SD_APP_EXTENSION macro for ios8 extensions
   pod 'SDWebImage+ExtensionSupport', '~> 3.7.1.2'
   - Homepage: https://github.com/rs/SDWebImage
   - Source:   https://github.com/glassoff/SDWebImage.git
   - Versions: 3.7.1.2, 3.7.1.1 [master repo]

这个时候,我们cd一个项目

然后:

1、touch podfile
2、vim podfile

然后

pod 'AFNetworking', '~> 3.1.0'

最后

pod install

但是这个时候又报错了,
[!] The dependency ` is not used in any concrete target.
[!] The dependency
SDWebImage (~> 4.0.0)` is not used in any concrete target.
解决办法

打开podfile

platform :ios,"8.0"

target "项目名称" do
pod 'SDWebImage', '~> 4.0.0'
end

然后在更新
pod install
显示如下信息,完成

Analyzing dependencies
Downloading dependencies
Installing SDWebImage (4.0.0)
Generating Pods project
Integrating client project

[!] Please close any current Xcode sessions and use `cityText.xcworkspace` for this project from now on.
Sending stats
Pod installation complete! There is 1 dependency from the Podfile and 1 total pod installed.
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/cishengchangan/article/details/79959761

那些年踩过的CSS坑(永久更新)

1、img 标签中的alt 与title的区别: alt  alt属性的实质作用是在图片无法正确显示时起到文本替代的作用,不过在IE6下还起到了title的作用。 title 鼠标滑过时显示的文字提示...
  • x_chengqq
  • x_chengqq
  • 2016-04-22 21:11:04
  • 1126

微信小程序踩坑总结

微信小程序踩坑总结一、样式 1.微信官方提供的rpx单位在横向可以很好的实现响应式,但在纵向方面表现不理想,各个设备的兼容情况并不好,因此纵向我依然选择用px为基本单位进行开发。 ...
  • AiceIce
  • AiceIce
  • 2017-07-17 12:31:55
  • 278

CocoaPods更新

最近使用cocoa pods时提示版本过低需要升级才能正常使用。但是在升级过程中又出现了问题。首先我是直接使用语句:sudo gem install cocoapods 进行更新升级的,没想到又报错了...
  • FlyingFireFish
  • FlyingFireFish
  • 2018-03-23 09:39:32
  • 293

致Android-那些年,我们一起踩过的坑

大爷的,从搞android至今,踩过的坑倒是不少,MD,要是同一个坑,踩一次也就算了,踩两次、多次那就显得狠low了…记录那些年,希望跟我踩同一个坑的同胞们一些帮助(主要是怕自己踩同一个坑,哈哈~~)...
  • yiluyoufeng
  • yiluyoufeng
  • 2016-06-18 23:29:23
  • 832

CocoaPods版本升级——本地CocoaPods更新

CocoaPods已经发布了正式版本,还是测试版本的,可能需要动动手指了。 这里不再详细的介绍怎么安装CocoaPods了,相信你来查找CocoaPods升级就应该安装过了,要是需要它的安装步骤和详细...
  • Cituses
  • Cituses
  • 2016-06-07 11:33:37
  • 7461

CocoaPods版本升级2016最新版

升级 OS X El Capitan 后,Time Machine 恢复下,随后因为遇到 octopress 无法更新博客问题,一番折腾 octopress 适配了 OS X El Capitan,然...
  • u012265444
  • u012265444
  • 2016-08-03 08:48:30
  • 2449

cocoapods search 获取不到最新库的解决方法

获取不到最新库的原因主要有两个:1.cocoapods的版本过低 2.还没有更新本地仓库解决方法: 1.更新pods在终端执行命令行 sudo gem install cocoapods有时候会...
  • Jayant_Y
  • Jayant_Y
  • 2016-12-07 14:34:42
  • 2585

前端踩的一些坑

今天用bootstrap modal 进行ajax发送数据时,发送数据时第一次点击,发送一次ajax提交,第二次点击发送两次ajax提交,第三次点击发送3次ajax提交...),原来是在标签上绑定了太...
  • leadn
  • leadn
  • 2017-02-15 16:36:28
  • 1238

百度地图sdk踩坑之旅

1.写在前面项目中需要加上路线规划,导航,添加覆盖物,因为我最开始项目中定位我使用的是百度定位,所以为了省事,接着使用百度地图sdk实现这些。这两天踩了很多百度地图的坑,记下来。因为一些原因,后面会说...
  • guozhaohui628
  • guozhaohui628
  • 2017-03-24 10:27:29
  • 1485

前端总结:踩过的坑以及一些冷知识

css css样式这一块坑比较多,有些情况不按常理出牌,在精确控制样式和大小时就会遇到这些坑。 1、 行内元素(比如img)默认会在末尾(或底部)留白/间隙,无法去除。解决办法:通过disp...
  • linysuccess
  • linysuccess
  • 2016-12-02 10:56:32
  • 864
收藏助手
不良信息举报
您举报文章:cocoapods最新踩坑以及更新
举报原因:
原因补充:

(最多只允许输入30个字)