cocoapods的升级更新

原创 2017年03月15日 19:30:58

最近使用cocoa pods时提示版本过低需要升级才能正常使用。


但是在升级过程中又出现了问题。

首先我是直接使用语句:sudo gem install cocoapods 进行更新升级的,没想到又报错了。


接着我在想是不是因为没有更新gem呢,于是就先更新下gem。

注意,更新gem时,使用语句:sudo gem update --system 


更新gem成功后,我又再次使用语句:sudo gem install cocoa pods 。还是提示失败?想想会不会是因为源路径出问题了,于是替换了源为:https://gems.ruby-china.org。


修改源后,继续使用语句:sudo gem install cocoa pods 。仍然异常。于是修改语句为:sudo gem install -n /usr/local/bin cocoa pods --pre 后则升级成功。




总结下来,要想成功升级cocoapods需要一个正确的操作流程和命令语句。

1、更新gem:sudo gem update --system

2、删除gem源:gem sources --remove https://ruby.taobao.org/

3、修改gem源:gem sources -a https://gems.ruby-china.org

4、查看gem源是否是最新的:gem sources -l

5、升级cocoapods:sudo gem install -n /usr/local/bin cocoapods --pre

6、查看升级后的cocoapods版本:pod --version



// cocoa pods更新后的语句使用示例
platform :ios, '8.0'
target:项目名称 do
pod 'SDWebImage', '~> 3.7.5'
end



版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/potato512/article/details/62235282

CocoaPods版本升级

升级CocoaPods的步骤和安装的时候差不多,具体参考如下步骤: 1.首先我们可以查看下当前的版本号命令如下: // 可用 "pod --version" 命令查看版...
  • yaoliangjun306
  • yaoliangjun306
  • 2017-09-03 17:51:58
  • 7444

CocoaPods更新

最近使用cocoa pods时提示版本过低需要升级才能正常使用。但是在升级过程中又出现了问题。首先我是直接使用语句:sudo gem install cocoapods 进行更新升级的,没想到又报错了...
  • FlyingFireFish
  • FlyingFireFish
  • 2018-03-23 09:39:32
  • 289

升级 Cocoapods 到1.2.0指定版本,降低版本及卸载

=====================升级版本=================== CocoaPods 1.1.0+ is required to build SnapKit 3.0.0+. ...
  • hsf_study
  • hsf_study
  • 2017-04-10 13:14:46
  • 7064

cocoapods:安装/更新Ruby环境教程

cocoapods安装前问题准备, 通过rvm安装ruby环境的详细步骤和问题
  • wangyanchang21
  • wangyanchang21
  • 2016-07-12 01:03:19
  • 10049

CocoaPods的安装,升级以及升级以后出现bug的解决方法(升级必看!)

在iOS项目中使用第三方类库可以说是非常常见的事,但是要正确地配置他们有时候是非常繁琐的事情,幸运的是CocoaPods是一个很好的解决方案。相信大家很多人也在使用CocoaPods,但是最近Coco...
  • zlj_jeck
  • zlj_jeck
  • 2016-05-27 08:04:34
  • 5143

2016 cocoapods的安装和使用以及版本升级遇到的问题

原文地址:http://www.cnblogs.com/yan520/p/5583362.html 一.CocoaPods是什么?   CocoaPods是一个负责管理iOS项目中...
  • fly601845
  • fly601845
  • 2016-08-08 17:20:45
  • 820

Mac 升级10.13.1 安装cocopods

Mac 升级到10.13.1 cocopods重新安装 终端提示:-bash: /usr/local/bin/pod: /System/Library/Frameworks/Ruby.frame...
  • jxy_fighting
  • jxy_fighting
  • 2017-11-23 15:37:33
  • 758

cocoapods 更新指定的库

当你的Cocoapods 执行pod install 或者执行pod update 命令的时候 出现Updating local specs repositories提示 你需要把命令修改成...
  • qq_29846663
  • qq_29846663
  • 2017-07-03 23:36:59
  • 7489

升级MacOS10.13.3之后,cocoapods不能使用的问题

解决方法:1、 sudo gem update --system    2、 sudo gem install -n /usr/local/bin cocoapods3、 再去使用pod就可以使用了。...
  • IOSSHIJIAZHUANG
  • IOSSHIJIAZHUANG
  • 2018-03-30 22:35:29
  • 33

cocoaPods更新问题解决

今天在运行项目时突然遇到异常报错:not find -lpod;一开始感觉很莫名其妙,随后意识到可能是cocoaPods的问题,于是尝试更新pod install,结果红色警告提示: The `ma...
  • XingXingRainLove
  • XingXingRainLove
  • 2016-11-21 11:56:45
  • 1431
收藏助手
不良信息举报
您举报文章:cocoapods的升级更新
举报原因:
原因补充:

(最多只允许输入30个字)