2018/1/25 可能是搜索

还是nwu17冬03-搜索专题

H - Find The Multiple

 

给定一个正整数n,请编写一个程序来寻找n的一个非零的倍数m,这个m应当在十进制表示时每一位上只包含0或者1。你可以假定n不大于200且m不多于100位。 
提示:本题采用Special Judge,你无需输出所有符合条件的m,你只需要输出任一符合条件的m即可。
Input
输入包含多组数据,每组数据仅一行,只包含一个正整数n (1 <= n <= 200).
Output
对于输入的每组n,都输出任一符合条件的m。即使有多个符合条件的m,你也只需要输出一个即可。
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

这题。。题目中说m不多于100位,吓得我以为要用数组模拟大数,其实long long就过了。。

按位dfs。条件是*10 和*10+1

#include <iostream>
#include <queue>

using namespace std;
typedef long long ll;

int main()
{
    int n;
    while (cin >> n && n > 0)
    {
        queue<ll> que;
        ll ans = 1;
        que.push(ans);
        while (que.size())
        {
            ll t = que.front();
            //cout << t << endl;
            que.pop();
            if (t % n == 0)
            {
                ans = t;
                break;
            }
            que.push(t * 10);
            que.push(t * 10 + 1);
        }
        cout << ans << endl;
    }
}

I - The Game

 

A game of Renju is played on a 19*19 board by two players. One player uses black stones and the other uses white stones. The game begins in an empty board and two play
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值