rectangle

D - rectangle

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25

解题思路:我先把输入的对角线的点全部变成副对角线,然后把下图中x1,y1,x2,y2找出来,相互比较计算出覆盖的矩形面积。


我的代码 :

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<string.h>
using namespace std;
struct point
{
    double x,y;
};
int main()
{
    point a, b, c, d;
    while (cin>>a.x>>a.y>>b.x>>b.y>>c.x>>c.y>>d.x>>d.y)
    {
        double x1, y1, x2, y2;
        if (a.x > b.x)
            swap (a.x , b.x);
        if (c.x > d.x)
            swap (c.x , d.x);
        if (a.y > b.y)
            swap (a.y , b.y);
        if (c.y > d.y)
            swap (c.y , d.y);
        x1 = max(a.x , c.x);
        x2 = min(b.x , d.x);
        y1 = min(b.y , d.y);
        y2 = max(a.y , c.y);
        double l , w;
        if (x2 < x1 || y2 > y1)
            cout << "0.00" << endl;
       else{
        l = x2 - x1;
        w = y1 - y2;
        printf("%.2lf\n", l*w);
       }
    }
    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值