A + B again (十六进制)

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input +A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output

0
2C
11
-2C
-90

我的思路一开始是用字符串存储十六进制的数组,然后把字符串转换成十进制,相加,再转换成十六进制。

我的代码:(注意求和的数字大小要开long long 才能存储15位数字)

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<string.h>
using namespace std;
int main()
{
    char a[100000], b[100000], c[100000];
    int n1, n2, i;
    while (cin >> a >> b)
    {
        int j, p1 = 0, p2 = 0;
        n1 = strlen (a);
        n1--;
        n2 = strlen (b);
        n2--;
        long long  s1 = 0, s2 = 0;
        if (a[0] == '+' || a[0] == '-')
            p1 = 1;
        if (b[0] == '+' || b[0] == '-')
            p2 = 1;
        for (i = n1; i >= p1 ; i--)
        {
            j = n1 - i;
            if (isdigit(a[i]))
                s1 = (((int)a[i]-48) * pow(16,j)) + s1;
            else if (isupper(a[i]))
                s1 = ((int)a[i] + 10 - 65) * pow(16,j) + s1;
            else if (islower(a[i]))
                s1 = ((int)a[i] + 10 - 97) * pow(16,j) + s1;
            else continue;
        }
        for (i = n2; i >= p2 ; i--)
        {
            j = n2 - i;
            if (isdigit(b[i]))
                s2 = (((int)b[i]-48) * pow(16, j)) + s2;
            else if (isupper(b[i]))
                s2 = ((int)b[i] + 10 - 65) * pow(16,j) + s2;
            else if (islower(b[i]))
                s2 = ((int)b[i] + 10 - 97) * pow(16,j) + s2;
            else continue;
        }
        if (a[0] == '-')
        s1 = -s1;
        if (b[0] == '-')
        s2 = -s2;
        s1 = s1 + s2;
        if (s1 < 0)
       {
           cout << "-";
           s1 = -s1;
           cout << setiosflags(ios::uppercase) << hex << s1 << endl;
        }
        else
        cout << setiosflags(ios::uppercase) << hex << s1 << endl;
    }
    return 0;
}


小伙伴也跟我思路差不多,但是他的十六进制转换很独特。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<string.h>
using namespace std;
int main()
{
    char a[100000], b[100000], c[100000];
    int n1, n2, i;
    while (cin >> a >> b)
    {
        int j, p1 = 0, p2 = 0;
        n1 = strlen (a);
        n1--;
        n2 = strlen (b);
        n2--;
        long long  s1 = 0, s2 = 0;
        if (a[0] == '+' || a[0] == '-')
            p1 = 1;
        if (b[0] == '+' || b[0] == '-')
            p2 = 1;
        for (i = n1; i >= p1 ; i--)
        {
            j = n1 - i;
            if (isdigit(a[i]))//判定数字
                s1 = (((int)a[i]-48) * pow(16,j)) + s1;
            else if (isupper(a[i]))//判定大写
                s1 = ((int)a[i] + 10 - 65) * pow(16,j) + s1;
            else if (islower(a[i]))//判定小写
                s1 = ((int)a[i] + 10 - 97) * pow(16,j) + s1;
            else continue;
        }
        for (i = n2; i >= p2 ; i--)
        {
            j = n2 - i;
            if (isdigit(b[i]))
                s2 = (((int)b[i]-48) * pow(16, j)) + s2;
            else if (isupper(b[i]))
                s2 = ((int)b[i] + 10 - 65) * pow(16,j) + s2;
            else if (islower(b[i]))
                s2 = ((int)b[i] + 10 - 97) * pow(16,j) + s2;
            else continue;
        }
        if (a[0] == '-')
        s1 = -s1;
        if (b[0] == '-')
        s2 = -s2;
        s1 = s1 + s2;
        if (s1 < 0)
       {
           cout << "-";
           s1 = -s1;
           cout << setiosflags(ios::uppercase) << hex << s1 << endl;//uppercase是控制输出的英文字母都是大写,hex控制十六进制。
       
        else
        cout << setiosflags(ios::uppercase) << hex << s1 << endl;
    }
    return 0;
}


不过网络的标准代码很快搞定,本渣很受教啊。

#include<stdio.h>
#include<math.h>
int main()
{
 

__int64 a,b;
 
while(scanf("%I64X%I64X",&a,&b)!=EOF)
 
  printf("%I64X\n",a+b);
 
return 0;
}




  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值