PAT 1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

 首先这个问题是一个很简单的问题,但是由于一些坑点我觉得我有必要记录一下。

思路:进制转换,int型数组判断回文。这个思路很简单也不会出现啥坑点。

我的思路:进制转换,int型数组转换为字符串,字符串判断回文。但是交了后,有一个测试样例没过,想了好久才发现。170 16 转换后的16进制数应该是10 10,这本来算是回文数的,但是如果转换成字符串再判断回文,很明显不是的。所以这种方法pass掉,当然也可以特殊处理。

错误代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<sstream>
#include<cstdio>
using namespace std;
string InTostring(int &i)//int型数组转字符串
{
  string s;
  stringstream ss(s);
  ss<<i;
  return ss.str();
}

int main()
{
  int n,b,flag=0;
  string str;
  cin>>n>>b;
  int z[1000],num=0;
  do {
    z[num++]=n%b;
    n=n/b;
  } while(n!=0);
  for(int i=num-1;i>=0;i--)
  {
    int &temp=z[i];
    str+=InTostring(temp);
  }
//问题点:Z中的元素有多少个  数组转字符串
//如何去判断数组中是否回文  数组转字符串判断回文
  for(int i=0,j=str.size()-1;i<str.size(),j>=0;i++,j--)
  {
    if(str[i]==str[j])
    {
      flag=1;
    }
    else
    {
      flag=0;
    }
  }
  if(flag==1)
  {
    cout<<"Yes"<<endl;
  }
  else
  {
    cout<<"No"<<endl;
  }
  for(int i=num-1;i>0;i--)
  {
    cout<<z[i]<<" ";
  }
  cout<<z[0]<<endl;
  return 0;
}
//我知道我错在哪里!170 16 输出的是10 10应该是回文的,
//但是我转换为字符串后,它就不是回文数了!!!!!!

正确代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<sstream>
#include<cstdio>
using namespace std;
bool Judge(int z[],int num)
{
  for(int i=0;i<=num/2;i++)
  {
    if(z[i]!=z[num-1-i])
    {
      return false;
    }
  }
  return true;
}
int main()
{
  int n,b;
  cin>>n>>b;
  int z[40],num=0;
  do {
    z[num++]=n%b;
    n=n/b;
  } while(n!=0);
  bool flag=Judge(z,num);
  if(flag==true)
  {
    cout<<"Yes"<<endl;
  }
  else
  {
    cout<<"No"<<endl;
  }
  for(int i=num-1;i>=0;i--)
  {
    printf("%d",z[i]);
    if(i!=0) printf(" ");
  }
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值