PAT 1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​ (a​i​​ b​i​​ ). Here, as usual, 0≤a​i​​ <b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​ =a​k−i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10^9 is the decimal number and 2≤b≤10^​9 is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−​​ …0
​​ ". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

注意:
1、测试点2,4出错是在于基底(进制)可能大于10,所以不能用字符串来存储,应用数组来存储

2、刷题应仔细读题;先有完整的思路再开始码代码,否则后面改代码比前面思考读题更浪费时间

我的代码:

#include<cstdio>
const int maxn = 1000000000;
int pal[maxn];//存储数字
bool isPal(int num)//看是否是回文数
{
    for (int i = 0 ;i <= num / 2 ;i++)
    {
        if (pal[i] != pal[num-1-i])
            return false;
    }
    return true;
}
int main()
{
    int n,base,num = 0;//num记录需要的数组大小
    scanf("%d%d",&n,&base);
    while (n != 0)
    {
        pal[num++] = n % base;
        n = n / base;
    }
    if (isPal(num) == true)
        printf("Yes\n");
    else
        printf("No\n");
    for (int i = num - 1 ;i >= 0 ;i--)
    {
        printf("%d",pal[i]);
        if (i > 0)
            printf(" ");
    }
    return 0;    
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值