A+B for Input-Output Practice(I~VII)

Your task is to Calculate a + b.Too easy?! Of course! I specially designed the problem for acm beginners.You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim
输入
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
输出
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
样例输入
1 5
10 20

#include<stdio.h>
int main()
{
    int n,m,i,sum;
    while(scanf("%d%d",&n,&m)!=EOF)
    {  
       sum=0;
       sum=m+n;
       printf("%d\n",sum);
    }
 }


A+B for Input-Output Practice (II)


题目描述
The first line integer means the number of input integer a and b.Your task is to Calculate a + b.
输入
Your task is to Calculate a + b. The first line integer means the numbers of pairs of input integers.
输出
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
样例输入
2
1 5
10 20
样例输出
6
30
        
        
#include<stdio.h> int main() {     int n,m,i,sum;     scanf("%d",&i);     for(int j=1;j<=i;j++)     {         scanf("%d%d",&n,&m);         sum=0;         sum=m+n;         printf("%d\n",sum);     }       }

A+B for Input-Output Practice (III)

题目描述
Your task is to Calculate a + b.
输入
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
输出
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
样例输入
1 5
10 20
0 0
样例输出
6
30

#include<stdio.h>
int main()
{
    int n,m,i,sum;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(m==0&&n==0)
          break;
        sum=0;
        sum=m+n;
        printf("%d\n",sum);
    }    
 } 
 

A+B for Input-Output Practice (IV)


题目描述
Your task is to Calculate the sum of some integers.
输入
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
输出
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
样例输入
4 1 2 3 4
5 1 2 3 4 5
0 
样例输出
10
15

#include<stdio.h>
int main()
{
    int n,m,i,sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
          break;
        sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            sum+=m;
        }
        printf("%d\n",sum);
    }
    return 0;
 }


A+B for Input-Output Practice (五)

题目描述
Your task is to calculate the sum of some integers.
输入
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
输出
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.
样例输入
4 1 2 3 4
5 1 2 3 4 5
样例输出
10
15

#include<stdio.h>
int main()
{
    int n,m,i,sum;
    
    while(scanf("%d",&n)!=EOF)
    {

        sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            sum+=m;
        }
        printf("%d\n",sum);
    }
    return 0;
 }

A+B for Input-Output Practice (六)

题目描述
Your task is to Calculate a + b.
输入
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
输出
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.
样例输入
1 5
10 20
样例输出
6

30
#include<stdio.h>
int main()
{
    int n,m,i,sum;
    
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        sum=0;
    
            sum=m+n;
        
        printf("%d\n\n",sum);
    }
    return 0;
 }

A+B for Input-Output Practice

题目描述
Your task is to calculate the sum of some integers
输入
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line
输出
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
样例输入
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
样例输出
10

15

6

#include<stdio.h>
int main()
{
    int n,m,i,d,sum;
    scanf("%d",&d);
    while((d--)&&scanf("%d",&n))
    {

        sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            sum+=m;
        }
        printf("%d\n\n",sum);
    }
    return 0;
 }

 
  • 13
    点赞
  • 45
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值