Hdu1240 Asteroids!(BFS) ---Java版

Asteroids!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5026 Accepted Submission(s): 3231


Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.


Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.


Sample Input
  
  
START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END

Sample Output
  
  
1 0 3 4 NO ROUTE


题意: 输入一个三维地图,三维皆为n,然后输入起点和终点坐标,求起点到终点的步数,如果不能到达则输出”NO ROUTE“。


思路:三维看起来虽然比较复杂,但其实能写出走法和约束规则,就没有什么大问题了。这里要注意的是输入坐标分别为y、x、z,还有,Java中三维不能像C一样赋值,如果要在定义时赋值则要有与维数相同的括号(之前用得少,不清楚)。方向数组就算一开始不能确定具体大小也没关系,先看走法,一共六个方向,每次只能走一步,所以共有2+2+2种走法,所以6 1 3,6表示方向,1表示每个方向具体,3表示每个坐标具体。


import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
         Scanner sc = new Scanner(System.in);
         
         while(sc.hasNext()){
        	 String str = sc.next();
        	 int n = sc.nextInt();
        	 char [][][]map = new char[n][n][n];
        	 boolean [][][] vis = new boolean[n][n][n];
        	 for(int i=0;i<n;i++){
        		 for(int j=0;j<n;j++){
        			String str2 = sc.next();  
        			 for(int k=0;k<n;k++){
        				 map[i][j][k] = str2.charAt(k);
        			 }
        		 }
        	 }
        	 Points st = new Points();
        	 Points ed = new Points();
        	 
        	 st.y = sc.nextInt();
        	 st.x = sc.nextInt();
        	 st.z = sc.nextInt();
        	 ed.y = sc.nextInt();
        	 ed.x = sc.nextInt();
        	 ed.z = sc.nextInt();
        	 st.step=0;
        	 ed.step=0;
        	
        	 String str2 = sc.next();
        	 
        	 int result = bfs(n,st,ed,map,vis);
        	 if(result==-1){
        		 System.out.println("NO ROUTE");
        	 }else{
        		 System.out.println(n+" "+result);
        	 }
        	 
         }
	}
	public static int bfs(int n,Points st,Points ed,char[][][] map,boolean[][][] vis){
		
		Queue2 que = new Queue2();
		que.push(st);
		vis[st.z][st.y][st.x]=true;
		int to[][][] = {
				{{ 1,0,0 }}, 
				{{-1,0,0}},
				{{0,1,0}},
				{{0,-1,0}},
				{{0,0,1}},
				{{0,0,-1}}
		};
		
		while(!que.isEmpty()){
			Points tq = que.pop();
			if(tq.x==ed.x && tq.y==ed.y && tq.z==ed.z ){
				return tq.step;
			}
			for(int i=0;i<6;i++){
				for(int j=0;j<1;j++){
						int fx = tq.x+to[i][j][0];
						int fy = tq.y+to[i][j][1];
						int fz = tq.z+to[i][j][2];
					  if(fx>=0 && fx<n && fy>=0 && fy<n && fz>=0 && fz<n && !vis[fz][fy][fx] && map[fz][fy][fx]!='X'){
						  vis[fz][fy][fx] = true;
						  que.push(new Points(fx, fy, fz,tq.step+1));
					  }
					
				}
			}
			
		}			
		return -1;
	}
}
class Points{
	int x,y,z,step;
	public Points(){
	}	
	public Points(int x, int y, int z ,int step) {
		this.x = x;
		this.y = y;
		this.z = z;
		this.step = step;
	}	
}
class Queue2{
	List<Points> list = new ArrayList<Points>();
	public void push(Points p){
		list.add(p);
	}
	
	public Points pop(){
		if(list.size()>0){
			return list.remove(0);			
		}else{
			return null;
		}
	}
	public boolean isEmpty(){
		if(list.size()==0){
			return true;
		}else{
			return false;
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值