Hdu1170 Balloon Comes!

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28744 Accepted Submission(s): 10830


Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.

Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input
  
  
4 + 1 2 - 1 2 * 1 2 / 1 2

Sample Output
  
  
3 -1 2 0.50

题意:输入t表示有t组数据,然后就是两个数字的运算。


心得:本来不想把这道题写到这里来的,因为水,但做着做着发现了一些知识上的漏洞,所以决定把写下来。

            这道题,我是用Java写的,第一次提交WA,以为是要hasNext(),改了以后提交,TLE,又测试了一下,发现除得到整数的情况有问题,原来Java中的Double型都是带小数点的,1就是1.0,这点原来还真没注意,于是判断了一下,如果结果是整数就用int相除,否则用结果为double型。也可以先取余判断是否能除尽。


import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
         Scanner sc = new Scanner(System.in);
         int t = sc.nextInt();
         
         while(t-->0){
        	 String str = sc.next();
        	 int a = sc.nextInt();
        	 int b = sc.nextInt();
        	 double sum=0;
        	 if(str.equals("+")){
        		 System.out.println(a+b);
        	 }else if(str.equals("-")){
        		 System.out.println(a-b);
        	 }else if(str.equals("*")){
        		 System.out.println(a*b);
        	 }else if(str.equals("/")){
        		 sum=a*1.0/b;
        		 int sum2 = a/b;
        		 if(sum2==sum){
        			 System.out.println(sum2);
        		 }else{
        			 System.out.printf("%.2f",sum);
        			 System.out.println();
        		 }
        	 }
        	 
         }
	 
	}

}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值