poj3468 A Simple Problem with Integers 线段树区间更新

A Simple Problem with Integers

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

思路:

一个线段树区间更新的板子题,lazy思想,具体不是太懂,就.........不写了

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
const int maxn = (int)1e5 + 10;
int a[maxn];
struct node
{
    int left,right;
    ll vue,num;
}tree[maxn << 2];

void build(int l,int r,int o)
{
    tree[o].left = l,tree[o].right = r;
    tree[o].num = 0;
    if (l == r)
    {
        tree[o].vue = a[l];
        return ;
    }
    int mid = (l + r) >> 1;
    build(l,mid,o << 1);
    build(mid + 1,r,o << 1 | 1);
    tree[o].vue = tree[o << 1].vue + tree[o << 1 | 1].vue;
}
void update(int l,int r,ll x,int o)
{
    if (tree[o].left == l && tree[o].right == r)
    {
        tree[o].num += x;
        return ;
    }
    tree[o].vue += x * (r - l + 1);
    int mid = (tree[o].left + tree[o].right) >> 1;

    if (r <= mid) update(l,r,x,o << 1);
    else if (l > mid) update(l,r,x,o << 1 | 1);
    else
    {
        update(l,mid,x,o << 1);
        update(mid + 1,r,x,o << 1 | 1);
    }
}
ll query(int l,int r,int o)
{
    if (tree[o].left == l && tree[o].right == r)
        return tree[o].vue + (r - l + 1) * tree[o].num;
    int mid = (tree[o].left + tree[o].right) >> 1;
    tree[o].vue += tree[o].num * (tree[o].right - tree[o].left + 1);
    update(tree[o].left,mid,tree[o].num,o << 1);
    update(mid + 1,tree[o].right,tree[o].num,o << 1 | 1);
    tree[o].num = 0;
    if (r <= mid) return query(l,r,o << 1);
    else if (l > mid) return query(l,r,o << 1 | 1);
    else return query(l,mid,o << 1) + query(mid + 1,r,o << 1 | 1);
}
int main()
{
    int n,m;
    while (~scanf("%d %d",&n,&m))
    {
        int u,v,x;
        char q[3];
        for (int i = 1;i <= n;i ++)
            scanf("%d",&a[i]);
        build(1,n,1);
        while (m --)
        {
            scanf("%s",q);
            if (q[0] == 'Q')
            {
                scanf("%d %d",&u,&v);
                printf("%lld\n",query(u,v,1));
            }
            else
            {
                scanf("%d %d %d",&u,&v,&x);
                update(u,v,x,1);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值