poj 3461 oulipo

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32025 Accepted: 12933

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

BAPC 2006 Qualification

题目大意:输入n组字符串,求串1在串2中的出现次数。

如果我们直接暴力枚举的话0(wt)肯定会超时,那么我们想到了字符串处理的常用算法——kmp算法

KMP 算法可在一个主文本字符串 S 内查找一个词 W 的出现位置。此算法通过运用对这个词在不匹配时本身就包含足够的信息来确定下一个匹配将在哪里开始的发现,从而避免重新检查先前匹配的字符。

kmp算法的核心就是失配函数。

失配函数的作用是使得 S 中的任意字符不会被多次匹配(这一点从我们刚才的实例中也能体现出来),从而实现线性的在 S 中查找 W。对于 W 中的任何位置,我们都希望能够查询那个位置前(不包括那个位置)有可能的 W 的最长初始字段的长度,这样就不用每次从 W[0] 开始比较。定义这个长度为 T[i]。我们使空串长度是 0。特别地,我们设置 T[0] = -1。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int t[1000003],len,len1,n;
char s[1000003],s1[1000003];
void calc_t()
{
	t[0]=-1;
	int j;
	for (int i=0;i<len1;i++)
	 {
	 	j=t[i];
	 	while (j!=-1&&s1[j]!=s1[i])
	 	 j=t[j];
	 	t[i+1]=++j;
	 }
}
int kmp()
{
	int i=0,j=0,sum=0;
	while (i<len)
	 {
	 	if (j==-1||s[i]==s1[j])
	 	 i++,j++;
	 	else
	 	 j=t[j];
	 	if (j==len1)
	 	 {
	 	 	sum++;
	 	 	j=t[j];
	 	 }
	 }
	return sum;
}
int main()
{
	scanf("%d\n",&n);
	for (int l=1;l<=n;l++)
	{
	gets(s1); gets(s); len=strlen(s); len1=strlen(s1);
	memset(t,0,sizeof(t));
	calc_t();
	int ans=kmp();
	printf("%d\n",ans);
    }
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值