bzoj 3050: [Usaco2013 Jan]Seating

3050: [Usaco2013 Jan]Seating

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 128   Solved: 73
[ Submit][ Status][ Discuss]

Description

To earn some extra money, the cows have opened a restaurant in their barn specializing in milkshakes. The restaurant has N seats (1 <= N <= 500,000) in a row. Initially, they are all empty. Throughout the day, there are M different events that happen in sequence at the restaurant (1 <= M <= 300,000). The two types of events that can happen are: 1. A party of size p arrives (1 <= p <= N). Bessie wants to seat the party in a contiguous block of p empty seats. If this is possible, she does so in the lowest position possible in the list of seats. If it is impossible, the party is turned away. 2. A range [a,b] is given (1 <= a <= b <= N), and everybody in that range of seats leaves. Please help Bessie count the total number of parties that are turned away over the course of the day.

m(m<=300,000) 个操作。操作分 2 种:
1. A p ,表示把编号最小的空着的长度为 p 的区间图上颜色。
2. L a b ,表示把从 a b 的区间(包括端点)全部擦干净(没颜色还是没颜色)。
Q :有多少个操作 1 不能实现?
 

Input

 

* Line 1: Two space-separated integers, N and M. 
* Lines 2..M+1: Each line describes a single event. It is either a line of the form "A p" (meaning a party of size p arrives) or "L a b" (meaning that all cows in the range [a, b] leave).

Output

 * Line 1: The number of parties that are turned away.

 

Sample Input

10 4
A 6
L 2 4
A 5
A 2
INPUT DETAILS: There are 10 seats, and 4 events. First, a party of 6 cows arrives. Then all cows in seats 2..4 depart. Next, a party of 5 arrives, followed by a party of 2.

Sample Output

1

OUTPUT DETAILS: Party #3 is turned away. All other parties are seated.



HINT

样例解释:

   首先将 1~6 图上颜色,再把 2~4 擦掉,这时不存在长度为 5 的空着的区间,该操作不能实现,跳过。最后把 2~3 图上颜色。所以不能实现的操作 1 有一个,即第三个操作。

Source



题解参见:poj 3667 hotel 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 500003
using namespace std;
int n,m,ans;
int sum[4*N],lx[N*4],rx[N*4],delta[4*N];
void update(int x)
{
  sum[x]=sum[x<<1]+sum[x<<1|1];
  lx[x]=rx[x]=sum[x];
}
void build(int now,int l,int r)
{
  if (l==r)
  {
    sum[now]=lx[now]=rx[now]=1;
    return;
  }
  int mid=(l+r)/2;
  build(now<<1,l,mid);
  build(now<<1|1,mid+1,r);
  update(now);
}
void pushdown(int x,int l,int r)
{
  if (!delta[x]) return;
  int mid=(l+r)/2;
  sum[x<<1]=lx[x<<1]=rx[x<<1]=(delta[x]==1?0:mid-l+1);
  sum[x<<1|1]=lx[x<<1|1]=rx[x<<1|1]=(delta[x]==1?0:r-mid);
  delta[x<<1]=delta[x<<1|1]=delta[x];
  delta[x]=0;
}
int find(int now,int l,int r,int x)
{
  if(l==r) return l;
  pushdown(now,l,r);
  int mid=(l+r)/2;
  if (sum[now<<1]>=x)
   return find(now<<1,l,mid,x);
  else
  if (rx[now<<1]+lx[now<<1|1]>=x)
   return mid-rx[now<<1]+1;
  else
   return find(now<<1|1,mid+1,r,x);
}
void update1(int x,int l,int r)
{
  int mid=(l+r)/2;
  sum[x]=max(max(sum[x<<1],sum[x<<1|1]),rx[x<<1]+lx[x<<1|1]);
  lx[x]=lx[x<<1]+(lx[x<<1]==mid-l+1?lx[x<<1|1]:0);
  rx[x]=rx[x<<1|1]+(rx[x<<1|1]==r-mid?rx[x<<1]:0);
}
void qjchange(int now,int l,int r,int ll,int rr,int v)
{
  if (l>=ll&&r<=rr)
  {
  	if (v==0)
  	 sum[now]=lx[now]=rx[now]=0;
  	else
  	 sum[now]=lx[now]=rx[now]=r-l+1;
  	delta[now]=v+1;
  	return;
  }
  pushdown(now,l,r);
  int mid=(l+r)/2;
  if (ll<=mid)
   qjchange(now<<1,l,mid,ll,rr,v);
  if (rr>mid)
   qjchange(now<<1|1,mid+1,r,ll,rr,v);
  update1(now,l,r);
}
int main()
{
  freopen("seating.in","r",stdin);
  freopen("seating.out","w",stdout);
  scanf("%d%d",&n,&m);
  build(1,1,n);
  for (int i=1;i<=m;i++)
  {
   char s[10]; scanf("%s",s);
   if (s[0]=='A')
   {
   	int x; scanf("%d",&x);
   	if (sum[1]<x)
   	 ans++;
   	else
   	 {
   	   int pos=find(1,1,n,x);
   	   qjchange(1,1,n,pos,pos+x-1,0);
   	 }
   }
   else
    {
      int x,y; scanf("%d%d",&x,&y);
      qjchange(1,1,n,x,y,1);
    }
  }
  printf("%d\n",ans);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值