poj 2425 A Chess Game(sg函数)

A Chess Game
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 3685 Accepted: 1505

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN

Hint

Huge input,scanf is recommended.

Source

PKU Monthly,CHEN Shixi(xreborner)

[Submit]   [Go Back]   [Status]   [Discuss]


题目大意:给出一个n个位置的有向无环图,M个棋子每个棋子只能沿着有向边移动,当不能再移动时,则输。问先手的输赢。

题解:sg函数,注意在求一个位置时,要保证他所能到达的位置已经求解过了。

另外需要注意存边的数组,刚开始开小了,就RE了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 10003
using namespace std;
int n,m,tot;
int point[N],sg[N],vis[N];
int next[1000003],v[1000003];
void add(int x,int y)
{
	tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y;
}
void dfs(int x)
{
	vis[x]=1;
	bool mark[N]; 
	memset(mark,0,sizeof(mark));
	for (int i=point[x];i;i=next[i])
	 {
	 	if (vis[v[i]]==0) dfs(v[i]);
	    mark[sg[v[i]]]=1;
	 }
	for (int i=0;i<=N;i++)
	 if (!mark[i])
	  {
	  	sg[x]=i;
	  	break;
	  }
}
int main()
{
	while (scanf("%d",&n)!=EOF)
	 {
	 	tot=0;
	 	memset(point,0,sizeof(point));
	 	memset(next,0,sizeof(next));
	 	for (int i=1;i<=n;i++)
	 	 {
	 	 	scanf("%d",&m);
	 	 	for (int j=1;j<=m;j++)
	 	 	 {
	 	 	 	int x; scanf("%d",&x);
	 	 	 	x++; add(i,x);
	 	 	 }
	 	 }
	 	memset(vis,0,sizeof(vis));
	 	for (int i=1;i<=n;i++)
	 	 if (vis[i]==0)
	 	  dfs(i);
	 	while (scanf("%d",&m)!=EOF)
	 	 {
	 	 	if (m==0) break;
	 	 	int ans=0;
	 	 	for (int i=1;i<=m;i++)  {
	 	 		int x; scanf("%d",&x);
	 	 		x++; ans^=sg[x];
	 	 	}
	 	    if (ans)  printf("WIN\n");
	 	    else printf("LOSE\n");
	 	 }
	 }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值