poj 2155 Matrix(二维线段树,树套树)

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 24131 Accepted: 8930

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

[Submit]   [Go Back]   [Status]   [Discuss]


题解:二维线段树。

区间修改点查询,因为是异或和,所以我们可以把当前点到跟的路径上的标记累加,就是标记不下放,但是统计时需要计算所有覆盖该点的标记。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m,t,ans;
struct data{
	int treey[4000];
	int l,r;
}treex[4000];
void buildy(int x,int now,int l,int r)
{
	treex[x].treey[now]=0;
	if (l==r)  return;
	int mid=(l+r)/2;
	buildy(x,now<<1,l,mid);
	buildy(x,now<<1|1,mid+1,r);
}
void build(int now,int l,int r)
{
	buildy(now,1,1,n);
	if (l==r)  return ;
	int mid=(l+r)/2;
	build(now<<1,l,mid);
	build(now<<1|1,mid+1,r);
}
void update(int x,int now,int l,int r,int ll,int rr)
{
	if (l>=ll&&r<=rr){
		treex[x].treey[now]^=1;
		return;
	}
	int mid=(l+r)/2;
	if (ll<=mid) update(x,now<<1,l,mid,ll,rr);
	if (rr>mid)  update(x,now<<1|1,mid+1,r,ll,rr);
}
void change(int now,int l,int r,int ll,int rr,int y1,int y2)
{
	if (l>=ll&&r<=rr) {
	   update(now,1,1,n,y1,y2);
	   return;
	}
	int mid=(l+r)/2;
	if (ll<=mid)  change(now<<1,l,mid,ll,rr,y1,y2);
	if (rr>mid)  change(now<<1|1,mid+1,r,ll,rr,y1,y2);
}
void query1(int x,int now,int l,int r,int y)
{
	ans^=treex[x].treey[now];
	if (l==r)  return;
	int mid=(l+r)/2;
	if (y<=mid) query1(x,now<<1,l,mid,y);
	else query1(x,now<<1|1,mid+1,r,y);
}
void query(int now,int l,int r,int x,int y)
{
	query1(now,1,1,n,y);
	if (l==r) return;
	int mid=(l+r)/2;
	if (x<=mid) query(now<<1,l,mid,x,y);
	else query(now<<1|1,mid+1,r,x,y);
}
int main()
{
	freopen("a.in","r",stdin);
	scanf("%d",&t);
	for (int i=1;i<=t;i++)
	{
		scanf("%d%d",&n,&m);
		build(1,1,n);
		for (int j=1;j<=m;j++)
		{
			char s[10]; scanf("%s",s);
			if (s[0]=='C'){
				int x1,y1,x2,y2; scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				change(1,1,n,x1,x2,y1,y2);
			}
			else{
				int x,y; scanf("%d%d",&x,&y);
				ans=0;
				query(1,1,n,x,y);
				printf("%d\n",ans);
			}
		}
		printf("\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值