pku 3468 A Simple Problem with Integers(线段树)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 44296 Accepted: 12961
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

 
题意:给定n个数,给一个区间所有数一同加d,或者查询一个区间的和
题解:线段树+lazy思想,开多个数组表示延迟标记,在add的时候只改变mark标记数组,查询的时候再改变线段树的区间值,从而防止线段树的效率退化成n
 
#include<stdio.h>
#include<string.h>
__int64 a[100005],c[400500],mark[400500],n;
void init(int l,int r,int pos)
{
    int mid=(l+r)/2;
    mark[pos]=0;
    if(l==r){ c[pos]=a[l]; return; }
    init(l,mid,2*pos),init(mid+1,r,2*pos+1);
    c[pos]=c[2*pos]+c[2*pos+1];
}
__int64 ques(__int64 l,__int64 r,__int64 pos,__int64 templ,__int64 tempr)
{
    __int64 mid=(l+r)/2;
    if(templ==l&&r==tempr) return c[pos]+mark[pos]*(r-l+1);
    if(mark[pos]!=0)
    {
        mark[2*pos+1]+=mark[pos];
        mark[2*pos]+=mark[pos];
        c[pos]+=mark[pos]*(r-l+1),mark[pos]=0;
    }
    if(templ>mid) return ques(mid+1,r,2*pos+1,templ,tempr);
    else if(tempr<=mid) return ques(l,mid,2*pos,templ,tempr);
    else return ques(l,mid,2*pos,templ,mid)+ques(mid+1,r,2*pos+1,mid+1,tempr);
}
void add(__int64 l,__int64 r,__int64 pos,__int64 templ,__int64 tempr,__int64 val)
{
    __int64 mid=(l+r)/2;
    if(templ==l&&r==tempr){ mark[pos]+=val; return;}
    c[pos]+=val*(tempr-templ+1);
    if(templ>mid) add(mid+1,r,2*pos+1,templ,tempr,val);
    else if(tempr<=mid) add(l,mid,2*pos,templ,tempr,val);
    else add(mid+1,r,2*pos+1,mid+1,tempr,val),add(l,mid,2*pos,templ,mid,val);
}
int main()
{
    __int64 m,i,x,y,z;
    char ch;

    while(scanf("%I64d%I64d",&n,&m)>0)
    {
        for(i=1;i<=n;i++) scanf("%I64d",a+i);
        init(1,n,1);
        for(i=0;i<m;i++)
        {
            getchar();
            scanf("%c",&ch);
            if(ch=='Q')
            {
                scanf("%I64d%I64d",&x,&y);
                printf("%I64d\n",ques(1,n,1,x,y));
            }
            else
            {
                scanf("%I64d%I64d%I64d",&x,&y,&z);
                add(1,n,1,x,y,z);
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值