hdu 5945 Fxx and game (dp+单调队列)

Fxx and game

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 347    Accepted Submission(s): 78


Problem Description
Young theoretical computer scientist Fxx designed a game for his students.

In each game, you will get three integers X,k,t .In each step, you can only do one of the following moves:

1.X=Xi(0<=i<=t) .

2. if k|X,X=X/k .

Now Fxx wants you to tell him the minimum steps to make X become 1.
 

Input
In the first line, there is an integer T(1T20) indicating the number of test cases.

As for the following T lines, each line contains three integers X,k,t(0t106,1X,k106)

For each text case,we assure that it's possible to make X become 1。
 

Output
For each test case, output the answer.
 

Sample Input
  
  
2 9 2 1 11 3 3
 

Sample Output
  
  
4 3
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5947  5946  5943  5942  5941 
 

Statistic |  Submit |  Discuss | Note

题解:dp+单调队列

f[i]表示到达数字i最少需要多少步 ,初始值f[1]=0

if (i%k==0) f[i]=min(f[i],f[i/k]+1)

f[i]=min(f[i],f[j]+1) i-t<=j<=i-1

然后用单调队列维护,使队列中的元素单调不降,并保证队列中元素的位置不小于i-t。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define N 1000003
using namespace std;
int n,k,t,x,p[N],pos[N],f[N];
int main()
{
	freopen("a.in","r",stdin);
	freopen("std.out","w",stdout);
	scanf("%d",&n);
	for (int i=1;i<=n;i++){
		scanf("%d%d%d",&x,&k,&t);
		memset(f,127,sizeof(f));
		f[1]=0; int head=1; int tail=1;
		p[tail]=f[1]; pos[tail]=1;
	    for (int i=2;i<=x;i++) {
	    	while(tail>head&&pos[head]<max(1,i-t)) head++;
	    	f[i]=min(f[i],p[head]+1);
	    	if (i%k==0) f[i]=min(f[i],f[i/k]+1);
	    	while (tail>=head&&f[i]<=p[tail]) tail--;
	    	++tail; p[tail]=f[i]; pos[tail]=i;
		}
		printf("%d\n",f[x]);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值