hdu - 5945 Fxx and game 【dp + 单调队列】

Fxx and game

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 413    Accepted Submission(s): 100


Problem Description
Young theoretical computer scientist Fxx designed a game for his students.

In each game, you will get three integers  X,k,t .In each step, you can only do one of the following moves:

1.X=Xi(0<=i<=t) .

2. if  k|X,X=X/k .

Now Fxx wants you to tell him the minimum steps to make  X  become 1.
 

Input
In the first line, there is an integer  T(1T20)  indicating the number of test cases.

As for the following  T  lines, each line contains three integers  X,k,t(0t106,1X,k106)

For each text case,we assure that it's possible to make  X  become 1。
 

Output
For each test case, output the answer.
 

Sample Input
  
  
2 9 2 1 11 3 3
 

Sample Output
  
  
4 3
 

Source
 
dp方程还是比较好推的, 关键使用单调队列进行优化。

#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
//#define LOACL
#define space " "
using namespace std;
typedef long long LL;
//typedef __int64 Int;
typedef pair<int, int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double PI = acos(-1.0);
const LL MOD = 1e9 + 7;
const int MAXN = 1e6 + 10;
int dp[MAXN], que[MAXN], loc[MAXN];
int X, k, t;
int main() {
	int T;
	scanf("%d", &T);
	while (T--) {
		scanf("%d%d%d", &X, &k, &t);
		dp[1] = 0; dp[0] = INF;
		int tail = 1, head = 1;
		que[head] = 0; loc[head] = 1;
		for (int i = 2; i <= X; i++) {
			dp[i] = INF;
			if (i%k == 0) dp[i] = dp[i/k] + 1;
			//找出队顶
			while (head <= tail && i - t > loc[head]) head++;
			dp[i] = min(dp[i], que[head] + 1);
			//新元素加入到队列
			while (head <= tail && dp[i] < que[tail]) tail--;
			que[++tail] = dp[i]; loc[tail] = i;
		}
		printf("%d\n", dp[X]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值