1651: [Usaco2006 Feb]Stall Reservations 专用牛棚
Time Limit: 10 Sec Memory Limit: 64 MBSubmit: 843 Solved: 479
[ Submit][ Status][ Discuss]
Description
Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. Help FJ by determining: * The minimum number of stalls required in the barn so that each cow can have her private milking period * An assignment of cows to these stalls over time
有N头牛,每头牛有个喝水时间,这段时间它将专用一个Stall 现在给出每头牛的喝水时间段,问至少要多少个Stall才能满足它们的要求
Input
* Line 1: A single integer, N
* Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.
Output
* Line 1: The minimum number of stalls the barn must have.
* Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
1 10
2 4
3 6
5 8
4 7
Sample Output
OUTPUT DETAILS:
Here's a graphical schedule for this output:
Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>
Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..
Stall 3 .. .. c3>>>>>>>>> .. .. .. ..
Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.
HINT
不妨试下这个数据,对于按结束点SORT,再GREEDY的做法 1 3 5 7 6 9 10 11 8 12 4 13 正确的输出应该是3
Source
题解:线段树。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 2000003
using namespace std;
int n,tr[N*4],delta[N*4];
void update(int now)
{
tr[now]=max(tr[now<<1],tr[now<<1|1]);
}
void pushdown(int now)
{
if (delta[now]) {
tr[now<<1]+=delta[now];
tr[now<<1|1]+=delta[now];
delta[now<<1]+=delta[now];
delta[now<<1|1]+=delta[now];
delta[now]=0;
}
}
void qjchange(int now,int l,int r,int ll,int rr)
{
if (ll<=l&&r<=rr) {
tr[now]+=1;
delta[now]+=1;
return;
}
pushdown(now);
int mid=(l+r)/2;
if (ll<=mid) qjchange(now<<1,l,mid,ll,rr);
if (rr>mid) qjchange(now<<1|1,mid+1,r,ll,rr);
update(now);
}
int main()
{
freopen("a.in","r",stdin);
scanf("%d",&n);
int m=1000000;
for (int i=1;i<=n;i++) {
int x,y; scanf("%d%d",&x,&y);
qjchange(1,1,m,x,y);
}
printf("%d\n",tr[1]);
}