bzoj 2527: [Poi2011]Meteors (树状数组+整体二分)

2527: [Poi2011]Meteors

Time Limit: 60 Sec   Memory Limit: 128 MB
Submit: 1218   Solved: 455
[ Submit][ Status][ Discuss]

Description

Byteotian Interstellar Union (BIU) has recently discovered a new planet in a nearby galaxy. The planet is unsuitable for colonisation due to strange meteor showers, which on the other hand make it an exceptionally interesting object of study.
The member states of BIU have already placed space stations close to the planet's orbit. The stations' goal is to take samples of the rocks flying by. The BIU Commission has partitioned the orbit into msectors, numbered from 1to m, where the sectors 1and mare adjacent. In each sector there is a single space station, belonging to one of the nmember states.
Each state has declared a number of meteor samples it intends to gather before the mission ends. Your task is to determine, for each state, when it can stop taking samples, based on the meter shower predictions for the years to come.
Byteotian Interstellar Union有N个成员国。现在它发现了一颗新的星球,这颗星球的轨道被分为M份(第M份和第1份相邻),第i份上有第Ai个国家的太空站。

这个星球经常会下陨石雨。BIU已经预测了接下来K场陨石雨的情况。
BIU的第i个成员国希望能够收集Pi单位的陨石样本。你的任务是判断对于每个国家,它需要在第几次陨石雨之后,才能收集足够的陨石。
输入:
第一行是两个数N,M。
第二行有M个数,第i个数Oi表示第i段轨道上有第Oi个国家的太空站。
第三行有N个数,第i个数Pi表示第i个国家希望收集的陨石数量。
第四行有一个数K,表示BIU预测了接下来的K场陨石雨。
接下来K行,每行有三个数Li,Ri,Ai,表示第K场陨石雨的发生地点在从Li顺时针到Ri的区间中(如果Li<=Ri,就是Li,Li+1,...,Ri,否则就是Ri,Ri+1,...,m-1,m,1,...,Li),向区间中的每个太空站提供Ai单位的陨石样本。
输出:
N行。第i行的数Wi表示第i个国家在第Wi波陨石雨之后能够收集到足够的陨石样本。如果到第K波结束后仍然收集不到,输出NIE。
数据范围:

数据范围: 1<=n,m,k<=3*10^5 1<=Pi<=10^9 1<=Ai<10^9

Input

The first line of the standard input gives two integers, n and m(1<=n,m<=3*10^5) separated by a single space, that denote, respectively, the number of BIU member states and the number of sectors the orbit has been partitioned into.
In the second line there are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the states owning stations in successive sectors.
In the third line there are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote the numbers of meteor samples that the successive states intend to gather.
In the fourth line there is a single integer k(1<=k<=3*10^5) that denotes the number of meteor showers predictions. The following klines specify the (predicted) meteor showers chronologically. The i-th of these lines holds three integers Li, Ri, Ai(separated by single spaces), which denote that a meteor shower is expected in sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if Li>Ri), which should provide each station in those sectors with Aimeteor samples (1<=Ai<10^9).
In tests worth at least 20% of the points it additionally holds that .

Output

 
Your program should print nlines on the standard output. The i-th of them should contain a single integer Wi, denoting the number of shower after which the stations belonging to the i-th state are expected to gather at least Pi samples, or the word NIE (Polish for no) if that state is not expected to gather enough samples in the foreseeable future.

Sample Input

3 5
1 3 2 1 3
10 5 7
3
4 2 4
1 3 1
3 5 2

Sample Output

3
NIE
1

HINT

Source

[ Submit][ Status][ Discuss]


题解:树状数组+整体二分

这道题必须写树状数组,线段树会TLE,刚开始写的线段树,后来就懒得改了。。。

说一下思路:每次二分时间,然后将[l,mid]之间的陨石雨加入到线段树中进行区间修改,然后对于每个国家计算当前的答案,如果>希望值,就讲这个国家扔到[l,mid]这一部分继续二分。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 1300003
#define LL long long 
using namespace std;
int lazy[N],lx[N],rx[N],ans[N];
LL val[N],delta[N],tr[N];
int point[N],next[N],v[N],tot;
int n,m,tt;
struct data{
	int opt;
	int pos,num;
	LL x;
}a[300100];
void add(int x,int y)
{
	tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y;
}
void clear(int x)
{
	lazy[x]=1;
	tr[x]=0; delta[x]=0;
}
void pushdown(int now,int l,int r)
{
	int mid=(l+r)/2; 
	if (lazy[now]) {
	  clear(now<<1); clear(now<<1|1);
	  lazy[now]=0;
    }
	if (delta[now]) {
		tr[now<<1]+=delta[now]*(LL)(mid-l+1);
		tr[now<<1|1]+=delta[now]*(LL)(r-mid);
		delta[now<<1]+=delta[now];
		delta[now<<1|1]+=delta[now];
		delta[now]=0;
	}
}
void update(int now)
{
	tr[now]=tr[now<<1]+tr[now<<1|1];
}
void qjchange(int now,int l,int r,int ll,int rr,LL v)
{
	if (ll<=l&&r<=rr) {
		tr[now]+=(LL)(r-l+1)*v;
		delta[now]+=v;
		return;
	}
	int mid=(l+r)/2;
	pushdown(now,l,r);
	if (ll<=mid) qjchange(now<<1,l,mid,ll,rr,v);
	if (rr>mid) qjchange(now<<1|1,mid+1,r,ll,rr,v);
	update(now);
}
LL find(int now,int l,int r,int x)
{
	if (l==r) return tr[now];
	int mid=(l+r)/2;
	pushdown(now,l,r);
	if (x<=mid) return find(now<<1,l,mid,x);
	else return find(now<<1|1,mid+1,r,x);
}
int cmp(data a,data b)
{
	return a.opt<b.opt;
}
void divide(int l,int r,int x,int y)
{
//	cout<<l<<" "<<r<<" "<<x<<" "<<y<<endl;
	if (l==r) {
		clear(1);
		for (int i=l;i<=r;i++) 
		 if (lx[i]<=rx[i])qjchange(1,1,m,lx[i],rx[i],val[i]);
	     else qjchange(1,1,m,lx[i],m,val[i]),qjchange(1,1,m,1,rx[i],val[i]);
		for (int i=x;i<=y;i++) {
			LL t=0;
		    for (int j=point[a[i].num];j;j=next[j]){
		       t+=find(1,1,m,v[j]);
		       if (t>=a[i].x) break;
		    }
		    if (t>=a[i].x) ans[a[i].num]=l;
		    else ans[a[i].num]=-1;
		}
		return;
	}
	int mid=(l+r)/2;
	clear(1);
	for (int i=l;i<=mid;i++) 
	  if (lx[i]<=rx[i])qjchange(1,1,m,lx[i],rx[i],val[i]);
	  else qjchange(1,1,m,lx[i],m,val[i]),qjchange(1,1,m,1,rx[i],val[i]);
	int x1=0; int y1=y-x+1;
	for (int i=x;i<=y;i++){
		LL t=0;
		for (int j=point[a[i].num];j;j=next[j]){
		  t+=find(1,1,m,v[j]);
		  if (t>=a[i].x) break;
	    }
		if (t>=a[i].x) a[i].opt=++x1;
		else a[i].opt=++y1,a[i].x-=t;
	}
	sort(a+x,a+y+1,cmp);
	divide(l,mid,x,x+x1-1);
	divide(mid+1,r,x+x1,y);
}
int main()
{
	freopen("met.in","r",stdin);
	freopen("met.out","w",stdout);
	scanf("%d%d",&n,&m);
	for (int i=1;i<=m;i++) {
		int x; scanf("%d",&x);
		add(x,i);
	}
	for (int i=1;i<=n;i++) scanf("%I64d",&a[i].x),a[i].num=i;
	scanf("%d",&tt);
	for (int i=1;i<=tt;i++) {
	  scanf("%d%d%I64d",&lx[i],&rx[i],&val[i]);
    }
    memset(ans,-1,sizeof(ans));
	divide(1,tt,1,n);
	for (int i=1;i<=n;i++)
	 if (ans[i]!=-1) printf("%d\n",ans[i]);
	 else printf("NIE\n");
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值