杭电1008 Elevator

向天空满舵!


Elevator

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31446    Accepted Submission(s): 17014


Problem Description

The highestbuilding in our city has only one elevator. A request list is made up with Npositive numbers. The numbers denote at which floors the elevator will stop, inspecified order. It costs 6 seconds to move the elevator up one floor, and 4seconds to move down one floor. The elevator will stay for 5 seconds at eachstop.

For a given request list, you are to compute the total time spent to fulfillthe requests on the list. The elevator is on the 0th floor at the beginning anddoes not have to return to the ground floor when the requests are fulfilled.

 

 

Input

There are multipletest cases. Each case contains a positive integer N, followed by N positivenumbers. All the numbers in the input are less than 100. A test case with N = 0denotes the end of input. This test case is not to be processed.

 

 

Output

Print the totaltime on a single line for each test case. 

 

 

Sample Input

1 2

3 2 3 1

0

 

 

Sample Output

17

41


#include <iostream>
using namespace std;
int main()
{
    int n,f[101]={0},i,time=0,total=0;   //n request的个数  f每个请求的层数  i计数 time每次移动的时间
    //total 总时间
    while(cin>>n&&n!=0)                     //输入request 为0时退出
    {
        for(i=0;i<n;i++)
            cin>>f[i+1];                              //输入每个请求
        for(i=0;i<n;i++)
        {
            if(f[i+1]>f[i])
                time=(f[i+1]-f[i])*6;                       //每次移动的时间
            else
                time=(f[i]-f[i+1])*4;
            total+=time;
        }
        total+=5*n;
        cout<<total<<endl;                            //输出总时间
        total=0;time=0;                 //计数器归0
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值