杭电1002 大数相加


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158007    Accepted Submission(s): 29966



Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
/*思路  一存储。大数肯定不能用int float double型存储,所以定义两个字符数组用于数字的输入。
        二处理。输入数字后,用strlen测量数字的长度,把数字转成int数组,倒序排列,方便相加。
                sum[i]=num1[i]+num2[i]+sum[i];sum[i+1]=sum[i]/10;
                如果最后一位相加大于10,则多出一位,数组长度要加一。
        三输出。倒序输出。
        完
        
                
/
/
*/
#include <iostream>
#include <string.h>          //字符串函数需使用此字符串
using namespace std;
int main()
{
    int t;
    char a[1001],b[1001];            //定义两个字符数组,用于大数的输入
    int lena,lenb,maxlen;                        //lena 数组a的长度,lenb 数组b的长度
    int num1[1001]={0},num2[1001]={0},sum[1001]={0},i,k=1;
    cin>>t;

    while(t--)
    {
        cin>>a>>b;
        lena=strlen(a);
        lenb=strlen(b);                   //使用strlen函数测量字符数组长度
        maxlen=lena>lenb?lena:lenb;
        for(i=0;i<lena;i++)                //把字符数组倒序存于int数组
            num1[i]=a[lena-i-1]-'0';
        for(i=0;i<lenb;i++)
            num2[i]=b[lenb-i-1]-'0';
        for(i=0;i<maxlen;i++)                    //相加
        {
            sum[i]=num1[i]+num2[i]+sum[i];
            sum[i+1]=sum[i]/10;
            sum[i]=sum[i]%10;

        }
        if(sum[i]==1)
            maxlen++;
        cout<<"Case "<<k<<':'<<endl;
        k++;
        cout<<a<<" + "<<b<<" = ";                              //输出
        for(i=maxlen-1;i>=0;i--)
            cout<<sum[i];
        cout<<endl<<endl;
        for(i=0;i<maxlen;i++)
        sum[i]=0,num1[i]=0,num2[i]=0;

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值