D - To the Max
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
Sample Output
15
题意:给定一个二维数组序列,求 最大的连续子序列块;
思路:枚举第i行到第j行,求出第i行到第j行的每一列的和sum[k](第K列的和),即可以把二维问题转化为一维问题,这时第i行到第j行中的最大子序列块,即求sum数组的最大的连续子序列和,假设为ans(i,j),那么这个题目所求的最大连续子序列块即max{ans(i,j)}
#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=110;
const int nmax = 23;
const double esp = 1e-9;
const double PI=3.1415926;
int a[N][N],sum[N];
int n;
int solve() //求sum数组中的最大连续子序列和
{
int maxl=-inf;
int ans=0;
for(int i=0; i<n; i++)
{
ans+=sum[i];
maxl=max(maxl,ans);
if(ans<0)
/*只有当前面的连续子序列和大于0,
才对后面的连续子序列有贡献,否则
还不如直接断开前面的连续子序列段,即置0
*/
ans=0;
}
return maxl;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=0; i<n; i++)
for(int j=0; j<n; j++)
{
scanf("%d",&a[i][j]);
}
int maxl=-inf;
for(int i=0; i<n; i++)
{
memset(sum,0,sizeof(sum));
for(int j=i; j<n; j++)
{
for(int k=0; k<n; k++)
sum[k]+=a[j][k];
//sum[k]的值为第i行到第j行第k列上的和
int ans=solve();
maxl=max(maxl,ans);
}
}
printf("%d\n",maxl);
}
return 0;
}