POJ 1942 Paths on a Grid

7 篇文章 0 订阅

Paths on a Grid

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 16218 Accepted: 3885


Description
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:


Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input
5 4
1 1
0 0

Sample Output
126
2

Source
Ulm Local 2002
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

//C(n, n+m)

int main(){
	long long n, m;
	long long i, j, ans;
	while(scanf("%lld%lld", &n, &m) != EOF && n != 0 || m != 0){
		if (n > m){
			i = n;
			n = m;
			m = i;
		}
		ans = 1;
		for (i = 1; i <= n; i++){
			j = i + m;
			ans = ans * j / i;
		}
		printf("%lld\n", ans);
	}
	return 0;
}
/*
这题数据又贱又阴险
输入范围说不超过32位整数,天真用int的孩子们就沦陷了...
输入过大,DP数组开不下,用组合数吧
即使输入不超int,乘的时候还是有可能超的,至少结果要long long
很多人直接double来乘,就可以随便乘除了吧,但总感觉有精度问题...
最后,结束条件是n==0&&m==0,凡是只有一个零的还得算...输出1... 
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值