POJ 2151 Check the difficulty of problems

7 篇文章 0 订阅

Check the difficulty of problems

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2674 Accepted: 1163


Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output
0.972

Source
POJ Monthly,鲁小石

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int M, T, N;
double pro[1010][35];
double f[35][35];

void calcf(int num){
	int i, j;
	for (i = 1; i <= M; i++) f[0][i] = 0;
	f[0][0] = 1;
	for (i = 1; i <= M; i++){
		f[i][0] = f[i - 1][0] * (1 - pro[num][i]);
		for (j = 1; j <= i; j++){
			f[i][j] = f[i - 1][j] * (1 - pro[num][i]) + f[i - 1][j - 1] * pro[num][i];
//			printf("f[%d][%d] = %f\n", i, j, f[i][j]);
		}
	}
}

int main(){
	int i, j, k;
	double p, q, ans;
	while(scanf("%d%d%d", &M, &T, &N), M && N && T){
		for (i = 1; i <= T; i++){
			for (j = 1; j <= M; j++){
				scanf("%lf", &pro[i][j]);
			}
		}
		ans = 1;
		p = 1;
		for (i = 1; i <= T; i++){
			q = 1;
			for (j = 1; j <= M; j++){
				q *= (1 - pro[i][j]);
			}
			p *= (1 - q);
		}
		ans -= 1 - p;
//		printf("pa = %f\n", 1 - p);
		p = 1;
		for (i = 1; i <= T; i++){
			q = 0;
			calcf(i);
			for (j = 1; j < N; j++){
				q += f[M][j];
			}
			p *= q;
		}
//		printf("pb = %f\n", p);
		ans -= p;
		printf("%0.3f\n", ans);
	}
	return 0;
}
/*
看了遍概率的课件...来推推:
A:至少1队0题
B:每队1..N-1题
A和B是互不相容的, P(AB) = 0
求P(~A~B)
P(~A|~B) = P(~A) + P(~B) - P(~A~B)
P(~A|~B) = 1 - P(AB)
综上P(~A~B) = P(~A) + P(~B) - 1 = 1 - P(A) - P(B)
P(B)DP的去求,f[i][j]为前i道题做出j道的概率
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值