POJ 3349 Snowflake Snow Snowflakes

7 篇文章 0 订阅

Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 20205 Accepted: 5269


Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output
Twin snowflakes found.

Source
CCC 2007

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define MAXN 100007
#define MAXE 100010

int n;
struct Ledge{
	int next;
	int val[6];
}edge[MAXE];
int head[MAXN], nEdge;

int addEdge(int i, int *val){
	int k;
	for (k = 0; k < 6; k++)
		edge[nEdge].val[k] = val[k];
	edge[nEdge].next = head[i];
	head[i] = nEdge;
	return nEdge++;
}

int hash(int *val){
	int k;
	k = (val[0] + val[2] + val[4]) & (val[1] + val[3] + val[5]);
	return k % MAXN;
}

int equal(int *a, int *b){
	int i, j, k;
	int s[15];
	for (i = 0; i < 6; i++) s[i] = b[i];
	for (i = 6; i < 12; i++) s[i] = s[i - 6];
	for (i = 0; i < 6; i++){
		for (j = 0; j < 6; j++)
			if (a[j] != s[i + j]) break;
		if (j >= 6) break;
	}
	if (i < 6) return 1;
	for (i = 11; i >= 5; i--){
		for (j = 0; j < 6; j++)
			if (a[j] != s[i - j]) break;
		if (j >= 6) break;
	}
	if (i >= 5) return 1;
	return 0;
}

int find(int *val){
	int i, j, k;
	k = hash(val);
	for (i = head[k]; i != -1; i = edge[i].next){
		if (equal(val, edge[i].val)) break;
	}
	if (i != -1) return 1;
	else{
		addEdge(k, val);
		return 0;
	}
}

int main(){
	int i, j, k, s[15], flag;
	while(scanf("%d", &n) != EOF){
		memset(head, 0xff, sizeof(head));
		nEdge = 0;		
		flag = 0;
		while(n--){
			for (i = 0; i < 6; i++) scanf("%d", &s[i]);
			if (flag) continue;
			if (find(s)) flag = 1;
		}
		if (flag) printf("Twin snowflakes found.\n");
		else printf("No two snowflakes are alike.\n");
	}
	return 0;
}
/*
求是否有同构序列
两种做法
1.对一个序列将其拆成12个同构序列,再存到hash表里
2.只存这一个序列,判重时再考虑同构

方法1会将数据扩大12倍,每加入一个序列要经过hash,判重等过程
方法2对hash函数要求同构的序列hash值相同
反正我方法1写TLE了,用的对v[i]*i依次异或,最后模100007,估计是加序列的过程消耗太大
方法2000MS+才过...用的对v[i]依次异或,最后模100007
(val[0] + val[2] + val[4]) & (val[1] + val[3] + val[5])这种确实很巧啊,满足同构的能相同
但在我的程序里跑了还慢100MS...
不知道哪里写慢了...
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值