Maximum Subsequence Sum

01-复杂度2 Maximum Subsequence Sum

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

代码

#include <iostream>
using namespace std;
int main(){
	int i,n;
	int x=0,y=0;//x,y要赋初值,不然会段错误,但是我也不知道为什么 
	int sum=0,maxsum=0,flag=0;
	int a[100010];
	cin>>n;
	for(i=0;i<n;i++){
		cin>>a[i];
	}
	for(i=0;i<n;i++){
		sum=sum+a[i];
		if(sum>maxsum){
			maxsum=sum;
			y=i;  //每次改变maxsum的时候记录连续子列和的最后一个元素
		}
		if (sum<0){
			sum=0; //如果和为负数那从下一个数开始重新加 
		}
		if (a[i]>=0){
			flag=1;
		}
	} 
	sum=0;
	for(i=y;i>=0;i--){
		sum=sum+a[i];
		if (sum==maxsum){
			x=i;
		//这里不要加break,但是我也不知道为什么 
		}
	} 
	if(maxsum>0&&flag==1) {
		cout << maxsum << " " << a[x] << " " << a[y] << endl;   //存在最大子列和的情况
    } 
    else if (flag==1)
		cout << 0 << " " << 0 << " " << 0 << endl;       //最大子列和为0的情况
	else if (flag==0)
		cout << 0 <<  " " << a[0] << " " << a[n-1] << endl;    //全为负数,输出第一个和最后一个

	return 0;
}

针对全为负数的情况引入flag。
用第一种最小子列和暴力解法一直做不出来,只好用第二种O(n)复杂度的思想。在自己电脑上跑没什么问题但是提交了总会有段错误和答案错误,不知道为什么。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值