Solve It
Input: standard input
Output: standard output
Time Limit: 1 second
Memory Limit: 32 MB
Solve the equation:
p*e-x + q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
where 0 <= x <= 1.
Input
Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: p, q, r, s, t and u(where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.
Output
For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.
Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1
Sample Output
0.7071
No solution
0.7554
二分查找方程的解,注意边界也要判断
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
double p,q,r,s,t,u;
double solve(double x)
{
return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
}
int main()
{
while(~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u))
{
double left=0,right=1,mid;
if(solve(left)*solve(right)>0)//如果值均为正或均为负,则01之间没有解
{
printf("No solution\n");
continue;
}
if(solve(left)==0)
{
printf("0.0000\n");
continue;
}
if(solve(right)==0)
{
printf("1.0000\n");
continue;
}
while(left<=right)
{
mid=(left+right)/2;
if(solve(mid)>-(1e-9)&&solve(mid)<1e-9) break;
if(solve(left)*solve(mid)<0) right=mid;
else left=mid;
}
printf("%.4lf\n",mid);
}
return 0;
}