Aggressive cows
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 4852 | Accepted: 2384 |
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C
* Lines 2..N+1: Line i+1 contains an integer stall location, xi
* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3 1 2 8 4 9
Sample Output
3
Hint
OUTPUT DETAILS:
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.
===========================
二分牛之间的距离
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[111111],n,c;
bool C(int x)
{
int temp=a[0],ans=1;
for(int i=1;i<n;i++)
{
if(a[i]-temp>=x)
{
ans++;
temp=a[i];
}
}
if(ans>=c) return 1;
else return 0;
}
int b_search()
{
int ans,l=0,r=a[n-1],mid;
while(l<=r)
{
mid=(l+r)/2;
if(C(mid))
{
ans=mid;
l=mid+1;
}
else r=mid-1;
}
return ans;
}
int main()
{
scanf("%d%d",&n,&c);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
int ans=b_search();
printf("%d\n",ans);
return 0;
}