ZOJ 3529 - A Game Between Alice and Bob(素因子+博弈)

1 篇文章 0 订阅
A Game Between Alice and Bob

Time Limit: 5 Seconds      Memory Limit: 262144 KB

Alice and Bob play the following game. A series of numbers is written on the blackboard. Alice and Bob take turns choosing one of the numbers, and replace it with one of its positive factor but not itself. The one who makes the product of all numbers become 1 wins. You can assume Alice and Bob are intelligent enough and Alice take the first turn. The problem comes, who is the winner and which number is Alice's first choice if she wins?

Input

This problem contains multiple test cases. The first line of each case contains only one number N (1<= N <= 100000) representing there are N numbers on the blackboard. The second line contains N integer numbers specifying the N numbers written on the blackboard. All the numbers are positive and less than or equal to 5000000.

Output

Print exactly one line for each test case. The line begins with "Test #c: ", where c indicates the case number. Then print the name of the winner. If Alice wins, a number indicating her first choice is acquired, print its index after her name, separated by a space. If more than one number can be her first choice, make the index minimal.

Sample Input
4
5 7 9 12
4
41503 15991 72 16057 
Sample Output
Test #1: Alice 1
Test #2: Bob


题目大意:黑板上有n个数,每一次操作可以将其中一个数变成除它本身之外的因数。Alice先开始,轮流操作,最后使黑板上的数字都为1的人获胜。如果是Alice获胜还需要输出她第一步变第几个数


每次只能操作一个数很容易想到nim游戏,对于这道题来说每一堆就是每个数字的所有素因子的个数之和

转换成普通的nim游戏之后就很容易了


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int num[5000100],p[5000100],a[5000100];
int cs=0,cnt=0,n;

void prime(){
    for(int i=2;i<=5000000;i++){
        if(!p[i]){
            num[i]++;
            for(int j=i+i;j<=5000000;j+=i){
                p[j]=1;
                int temp=j;
                int z=0;
                while(temp%i==0)
                {
                    temp/=i;
                    z++;
                }
                num[j]+=z;
            }
        }
    }
}

int main()
{
    memset(num,0,sizeof(num));
    memset(p,0,sizeof(p));
    prime();
    while(~scanf("%d",&n)){
        int temp=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            //cout<<"num="<<num[a[i]]<<" ";
            temp^=num[a[i]];
        }
        printf("Test #%d: ",++cs);
        if(temp==0) printf("Bob\n");
        else{
            for(int i=0;i<n;i++){
                int ans=temp^num[a[i]];
                if(ans<=num[a[i]]){
                    printf("Alice %d\n",i+1);
                    break;
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值