Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10
7 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2 10 20
Sample Output
7 19
Source
=====================================
求一个数有N多少位:log10(N)+1
所以log10(1*2*3*……*n)+1=log10(1)+log10(2)+……+log10(N)+1
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
{
int t,n;
cin>>t;
while(t--)
{
double sum=0;
cin>>n;
for(int i=1;i<=n;i++)
{
sum+=log10((double)i);
}
cout<<(int)sum+1<<endl;
}
return 0;
}