Secret Research
Secret Research |
At a certain laboratory results of secret research are thoroughly encrypted. A result of a single experiment is stored as an information of its completion:
`positive result', `negative result', `experiment failed' or `experiment not completed'
The encrypted result constitutes a string of digits S, which may take one of the following forms:
positive result S = 1 or S = 4 or S = 78 negative result S = S35 experiment failed S = 9S4 experiment not completed S = 190S
(A sample result S35 means that if we add digits 35 from the right hand side to a digit sequence then we shall get the digit sequence corresponding to a failed experiment)
You are to write a program which decrypts given sequences of digits.
Input
A integer n stating the number of encrypted results and then consecutive n lines, each containing a sequence of digits given as ASCII strings.
Output
For each analysed sequence of digits the following lines should be sent to output (in separate lines):
+ for a positive result - for a negative result * for a failed experiment ? for a not completed experiment
In case the analysed string does not determine the experiment result, a first match from the above list should be outputted.
Sample Input
4 78 7835 19078 944
Sample Output
+ - ? *
Miguel A. Revilla
2000-01-10
================================
直接按照题意寻找字符即可
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char str[1111];
int main()
{
int t;
scanf("%d",&t);
getchar();
while(t--)
{
gets(str);
int len=strlen(str);
if((len==1&&(str[0]=='1'||str[0]=='4'))||(len==2&&str[0]=='7'&&str[1]=='8'))
cout<<"+"<<endl;
else if(str[len-2]=='3'&&str[len-1]=='5')
cout<<"-"<<endl;
else if(str[0]=='9'&&str[len-1]=='4')
cout<<"*"<<endl;
else cout<<"?"<<endl;
}
return 0;
}