单调队列——HDU 3415 Max Sum of Max-K-sub-sequence

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5216    Accepted Submission(s): 1890


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

Sample Input
  
  
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

Sample Output
  
  
7 1 3 7 1 3 7 6 2 -1 1 1

题目与单调队列—— HDU 4193 Non-negative Partial Sums类似,不在赘述,直接给出代码:

#include <stdio.h>

#define MAX_NUM	100000
#define NEGATIVE_INF -0x7ffffff

int sum[MAX_NUM*2+5];	//存储循环序列的前段和
int n;					//序列长度
int k;					//子序列的最大长度

int mq[MAX_NUM+5];		//单调不增队列,队列元素为a[]的下标
int front;				//队首指针
int rear;				//队尾指针,指向队尾的下一个位置

inline void InitMonotonicQueue(void)
{
	front = rear = 0;
}

inline bool IsEmpty(void)
{
	return front == rear;
}

void Push(int i)
{
	while (!IsEmpty() && sum[mq[rear-1]] < sum[i])
	{
		rear--;
	}
	mq[rear++] = i;
}

inline int Front(void)
{
	return mq[front];
}

inline void Pop(void)
{
	front++;
}

int main(void)
{
	int ncases;
	scanf("%d", &ncases);
	
	while (ncases-- != 0)
	{
		scanf("%d%d", &n, &k);
		int i;
		for (i = 1; i <= n; i++)
		{
			scanf("%d", &sum[i]);
		}

		for (i = n+1; i < n+k; i++)
		{
			sum[i] = sum[i-n];
		}

		for (i = 2; i < n+k; i++)
		{
			sum[i] += sum[i-1];
		}

		InitMonotonicQueue();
		for (i = 1; i <= k; i++)
		{
			Push(i);
		}
		int maxSum = sum[Front()];
		int startPos = 1, endPos = Front();

		for (i = k+1; i < n+k; i++)
		{
			if (!IsEmpty() && Front() + k <= i)
			{
				Pop();
			}
			Push(i);
			int p = Front();
			int s = sum[p] - sum[i-k];
			if (s > maxSum)
			{
				maxSum = s;
				startPos = i - k + 1;
				endPos = p;
			}
		}
		if (endPos > n)
		{
			endPos = endPos % n;
		}
		printf("%d %d %d\n", maxSum, startPos, endPos);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

庞老板

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值