Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9769 | Accepted: 6959 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
解题思路:单纯的快速矩阵幂
快速矩阵幂模板:
Matrix add(Matrix a,Matrix b){
Matrix ans;
for (int i=0;i<2;i++){
for (int j=0;j<2;j++){
ans.mat[i][j]=a.mat[i][j]+b.mat[i][j];
if (ans.mat[i][j]>=m){
ans.mat[i][j]%=m;
}
}
}
return ans;
}
Matrix mul(Matrix a,Matrix b){
Matrix ans;
for (int i=0;i<2;i++){
for (int j=0;j<2;j++){
ans.mat[i][j]=0;
for (int k=0;k<2;k++){
ans.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
if (ans.mat[i][j]>=m){
ans.mat[i][j]%=m;
}
}
}
}
return ans;
}
Matrix Init(){
Matrix ans;
for (int i=0;i<2;i++){
for (int j=0;j<2;j++){
if (i==j)
ans.mat[i][j]=1;
else
ans.mat[i][j]=0;
}
}
return ans;
}
Matrix exp(Matrix a,int k){
Matrix ans=Init();
while (k){
if (k&1)
ans=mul(ans,a);
a=mul(a,a);
k>>=1;
}
return ans;
}
参考代码:
#include <iostream>
using namespace std;
int m=10000;
struct Matrix{
long long mat[2][2];
};
Matrix add(Matrix a,Matrix b){
Matrix ans;
for (int i=0;i<2;i++){
for (int j=0;j<2;j++){
ans.mat[i][j]=a.mat[i][j]+b.mat[i][j];
if (ans.mat[i][j]>=m){
ans.mat[i][j]%=m;
}
}
}
return ans;
}
Matrix mul(Matrix a,Matrix b){
Matrix ans;
for (int i=0;i<2;i++){
for (int j=0;j<2;j++){
ans.mat[i][j]=0;
for (int k=0;k<2;k++){
ans.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
if (ans.mat[i][j]>=m){
ans.mat[i][j]%=m;
}
}
}
}
return ans;
}
Matrix Init(){
Matrix ans;
for (int i=0;i<2;i++){
for (int j=0;j<2;j++){
if (i==j)
ans.mat[i][j]=1;
else
ans.mat[i][j]=0;
}
}
return ans;
}
Matrix exp(Matrix a,int k){
Matrix ans=Init();
while (k){
if (k&1)
ans=mul(ans,a);
a=mul(a,a);
k>>=1;
}
return ans;
}
int main(){
Matrix a;
a.mat[0][0]=a.mat[0][1]=a.mat[1][0]=1;
a.mat[1][1]=0;
int n;
while (cin>>n&&n!=-1){
Matrix ans=exp(a,n);
cout<<ans.mat[0][1]%m<<endl;
}
return 0;
}