poj3070Fibonacci

poj3070Fibonacci:http://poj.org/problem?id=3070

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11699 Accepted: 8306

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

学习了矩阵快速幂,练练手,这题就是最基本的矩阵快速幂;

感觉做这类的题最困难的就是找出那个初始矩阵,只要找到了,问题就迎刃而解了。

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
const int mod = 10000;
typedef long long LL;

typedef struct Node
{
    LL a[2][2];
} node;

node fun(node x,node y)
{
    node tem = {0,0,0,0};
    for(int i = 0; i < 2; i++)
        for(int j = 0; j < 2; j++)
            for(int k = 0; k < 2; k++)
                tem.a[i][j] += x.a[i][k] * y.a[k][j],
                               tem.a[i][j] %= mod;
    return tem;
}
LL quickpow(LL n)
{
    node ans = {1,0,
                0,1
               },
         tem = {1,1,
                1,0
               };
    while(n)
    {
        if(n & 1)ans = fun(ans,tem);
        n >>= 1;
        tem = fun(tem,tem);
    }
    return (ans.a[0][0] + ans.a[0][1]) % mod;
}
int main()
{
//    freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n))
    {
        if(n == -1)break;
        if(n == 0)printf("0\n");
        else if(n <= 2)printf("1\n");
        else printf("%lld\n",quickpow(n - 2));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值