UVa 489 Hangman Judge

Hangman Judge

In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each
game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game
of hangman, and are given as follows:
1. The contestant tries to solve to puzzle by guessing one letter at a time.
2. Every time a guess is correct, all the characters in the word that match the guess will be “turned
over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will
be counted as “solved”.
3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which
needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

______
| |
| O
| /|\
| |
| / \
__|_
| |______
|_________|
  1. If the drawing of the hangman is completed before the contestant has successfully guessed all the
    characters of the word, the contestant loses.
  2. If the contestant has guessed all the characters of the word before the drawing is complete, the
    contestant wins the game.
  3. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.
    Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins,
    loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower
case. The first line of each section will contain a number to indicate which round of the game is being
played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made
by the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing
as well as the result of the game. There are three possible results:
You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.


题目中文名:刽子手游戏
翻译自己解决

书上的看起来就复杂

这段代码我用udebug调试5次以上
一开始还担心超时,不过还好没有

主要是几个问题
1.对字母重复出现的处理,因为是单词里有那个字母,所有该字母都会显示出来,所以要对标准单词所有字母进行遍历循环
2.对测试字母数大于标准字母数量,但提前通过测试

t
stywerewroiewru,虽然错误字母超过7个,但是在前7个字母里面有t,所以仍然算是win

#include <cstdio>
#include <cstring>

int main()
{
    int n;
    while(scanf("%d",&n))
    {
        if(n==-1)
            break;
        char s[100],st[100];
        scanf("%s%s",st,s);
        int cnt=0;
        int bog=0;
        int j,k,i;
        for(i=0; i<strlen(s); i++)
        {
            int flag=0;//flag是表示是否这个字母在标准单词里能找到
            for(j=0; j<strlen(st); j++)
            {
                if(s[i]==st[j])//对标准单词所有字母进行遍历循环,不能检测到正确的就跳出循环
                {
                    st[j]=' ';//检测过的,变为‘ ’
                    cnt++;
                    flag=1;
                }
            }
            for(k=0; k<i; k++)//检测这个字母是否重复出现,重复出现的字母也算是错误的
                if(s[i]==s[k])
                    flag=1;
            if(flag==0)//如果之前没有出现过,并且标准单词里面没有,则要给错误次数加上1
                bog++;//bog是错误的次数
            if(cnt==strlen(st))//这里就是对如果满足条件,提前跳出循环输出结果
                break;
        }
        printf("Round %d\n",n);
        if(cnt==strlen(st)&&bog<=6)
            printf("You win.\n");
        else if(bog>6)
            printf("You lose.\n");
        else if(bog<=6)
            printf("You chickened out.\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值