Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input
The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.
Output
For each test case write one line on the standard output:
Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1
Sample Output
Test case 1: 5
题意:东边和西边分别有n和m个城市,编号从1到x(y)
题目给出xi和yi表示连接 东边第xi座城市 和 西边第yi座城市
问你有多少个交点
思路:
按照x递增的顺序,求y数组有多少个逆序对(也可以反过来)
因为当y递减时,必定和之前的路有交点,交点数就是此时yi的构成的逆序对数,
代码实现:
用树状数组优化计算
用sum(i)计算出i前面有多少个数,包括它本身,在用此时数组已存的数据量减去sum(i),就求出此时的逆序对数
放入xi,即让c[xi]加1,然后更新c[xi+lowbit(xi)],
求sum[i],即求a[0]+a[1]+......+a[i]
坑点:要用long long int
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Lowbit(x) (x&(-x))
#define INF 0x3f3f3f3f
typedef long long int LL;
using namespace std;
const int N = 1e6 + 10;
struct Road
{
int l,r;
};
struct Road sam[N];
int C[N];
int cmp(struct Road a,struct Road b)
{
if(a.l==b.l)
return a.r<b.r;
return a.l<b.l;
}
int sum(int *C,int p)
{
int i,ans=0;
for(i=p; i>0; i-=Lowbit(i))
ans+=C[i];
return ans;
}
void Update(int *C,int p,int v)
{
int i;
for(i=p; i<N; i+=Lowbit(i))
C[i]+=v;
}
int main()
{
int T,z=0;
scanf("%d",&T);
while(T--)
{
int C[N]={0};
LL ans=0;
int i,n,m,k;
scanf("%d%d%d",&n,&m,&k);
for(i=0;i<k;i++){
scanf("%d%d",&sam[i].l,&sam[i].r);
}
sort(sam,sam+k,cmp);
for(i=0;i<k;i++){
Update(C,sam[i].r,1);
ans+=(LL)(i-sum(C,sam[i].r)+1);
}
printf("Test case %d: %lld\n",++z,ans);
}
return 0;
}